码迷,mamicode.com
首页 > 其他好文 > 详细

1013. Battle Over Cities (25)

时间:2015-02-25 21:11:19      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:c++   pat   

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0

0

#include<iostream>
#include<string.h>
using namespace std;
#include<queue>
#define  N 1001
int main()
{
    int n,m,k,i,j,t,c1,c2;
    bool highways[N][N];
    int concern[N];
    memset(highways,0,sizeof(highways));
    memset(concern,0,sizeof(concern));
    cin>>n;
    cin>>m;
    cin>>k;
    for(i=0;i<m;i++){
        cin>>c1;
        cin>>c2;
        highways[c1][c2]=true;
        highways[c2][c1]=true;
    }
    for(i=0;i<k;i++){
        cin>>concern[i];
    }
    for(i=0;i<k;i++){
        int visit[N],count,tmp;
        queue<int> q;
        memset(visit,0,sizeof(visit));
        visit[concern[i]]=1;
        count=0;
        for(j=1;j<=n;j++){
            if(visit[j]!=1){
                queue<int> dq;
                visit[j]=1;
                dq.push(j);
                //对与被占领城市的直接相连的每个城市做BFS
                while(!dq.empty()){
                    tmp=dq.front();
                    dq.pop();
                    for(t=0;t<=n;t++){
                        if(highways[tmp][t]!=false&&visit[t]!=1){
                            dq.push(t);
                            visit[t]=1;
                        }
                    }
                }
                /*如果现有节点可以遍历所有了所有点,不需要加边,退出。
                否则独立“孤岛”+1,通过下一个直接相连节点且未被访问的节点,寻找下一个孤岛*/
                count++;
            }
        }
        cout<<count-1<<endl;/*需要添加的路,就是连接各个孤岛所需要的最少路径*/
    }
    return 0;
}


1013. Battle Over Cities (25)

标签:c++   pat   

原文地址:http://blog.csdn.net/jason_wang1989/article/details/43939843

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!