码迷,mamicode.com
首页 > 其他好文 > 详细

SGU 495 Kids and Prizes 概率dp

时间:2015-02-26 01:23:18      阅读:207      评论:0      收藏:0      [点我收藏+]

标签:

题意:

有N个箱子放有礼物,M个人依次取。如果取到的箱子有礼物,则拿走礼物。无论有没有拿到礼物,都将箱子原状放回。(所以就有可能后面的人拿到前面的人拿过的箱子,然后就没得到奖品)。问,最后能拿走的礼物数量的期望。

两种思路,给跪了,,,还是没有想出来。。。。

m个人是独立的。
对于每个礼物不被人选中的概率为((n-1)/n)^m
那么不被选中的礼物数的期望就是 n*((n-1)/n)^m
所以答案就是  n-n*((n-1)/n)^m;

   这个地方自己老想着求1/n,结果没转过来。。。orz


概率dp

那么这道题目就是:设dp[i] 表示i个人拿过以后,主办方送出礼物的期望数量。

那么,对于第i个人,可能拿到,也可能没拿到礼物,转移方程就是:

dp[i] = (N-dp[i-1])/N  *  (dp[i-1] + 1)  +      (dp[i-1])/N   *   dp[i-1];

               拿到的概率   拿到的话就要多送一个  没拿到的概率  没拿到那还是一样


Description



ICPC (International Cardboard Producing Company) is in the business of producing cardboard boxes. Recently the company organized a contest for kids for the best design of a cardboard box and selected M winners. There are N prizes for the winners, each one carefully packed in a cardboard box (made by the ICPC, of course). The awarding process will be as follows:
  • All the boxes with prizes will be stored in a separate room.
  • The winners will enter the room, one at a time.
  • Each winner selects one of the boxes.
  • The selected box is opened by a representative of the organizing committee.
  • If the box contains a prize, the winner takes it.
  • If the box is empty (because the same box has already been selected by one or more previous winners), the winner will instead get a certificate printed on a sheet of excellent cardboard (made by ICPC, of course).
  • Whether there is a prize or not, the box is re-sealed and returned to the room.
The management of the company would like to know how many prizes will be given by the above process. It is assumed that each winner picks a box at random and that all boxes are equally likely to be picked. Compute the mathematical expectation of the number of prizes given (the certificates are not counted as prizes, of course).

Input

The first and only line of the input file contains the values of N and M ( 技术分享).

Output

The first and only line of the output file should contain a single real number: the expected number of prizes given out. The answer is accepted as correct if either the absolute or the relative error is less than or equal to 10 -9.

Sample Input

sample input
sample output
5 7
3.951424

sample input
sample output
4 3
2.3125

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
int main()
{
    int n,m;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        printf("%.9lf\n",n-n*1.0*pow(((1.0*n-1)/(n*1.0)),m));
    }
    return 0;
}

概率dp

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#include<cstring>
using namespace std;
int main()
{
    int n,m;
    double dp[100005];
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        dp[0]=0;
        dp[1]=1;
        for(int i=2;i<=m;i++)
            dp[i]=dp[i-1]*(1-dp[i-1])+dp[i-1]*(dp[i-1]-1.0/n);
        double s=0;
        for(int i=1;i<=m;i++)
            s+=dp[i];
            printf("%.9lf\n",s);
    }
    return 0;
}

真心氺题。。。。。。不说了都是泪

SGU 495 Kids and Prizes 概率dp

标签:

原文地址:http://blog.csdn.net/wweiainn/article/details/43945011

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!