码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 712(二叉树模拟)

时间:2014-06-03 00:53:43      阅读:335      评论:0      收藏:0      [点我收藏+]

标签:二叉树   模拟   uva   

L - S-Trees
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
Appoint description: 

Description

bubuko.com,布布扣


  S-Trees 

A Strange Tree (S-tree) over the variable set bubuko.com,布布扣 is a binary tree representing a Boolean function bubuko.com,布布扣. Each path of the S-tree begins at the root node and consists of n+1 nodes. Each of the S-tree‘s nodes has a depth, which is the amount of nodes between itself and the root (so the root has depth 0). The nodes with depth less than n are called non-terminal nodes. All non-terminal nodes have two children: the right child and the left child. Each non-terminal node is marked with some variable xi from the variable set Xn. All non-terminal nodes with the same depth are marked with the same variable, and non-terminal nodes with different depth are marked with different variables. So, there is a unique variable xi1 corresponding to the root, a unique variable xi2 corresponding to the nodes with depth 1, and so on. The sequence of the variables bubuko.com,布布扣 is called the variable ordering. The nodes having depth n are called terminal nodes. They have no children and are marked with either 0 or 1. Note that the variable ordering and the distribution of 0‘s and 1‘s on terminal nodes are sufficient to completely describe an S-tree.

As stated earlier, each S-tree represents a Boolean function f. If you have an S-tree and values for the variables bubuko.com,布布扣, then it is quite simple to find out what bubuko.com,布布扣 is: start with the root. Now repeat the following: if the node you are at is labelled with a variable xi, then depending on whether the value of the variable is 1 or 0, you go its right or left child, respectively. Once you reach a terminal node, its label gives the value of the function.

bubuko.com,布布扣

Figure 1: S-trees for the function bubuko.com,布布扣

On the picture, two S-trees representing the same Boolean function, bubuko.com,布布扣, are shown. For the left tree, the variable ordering is x1x2x3, and for the right tree it is x3x1x2.

The values of the variables bubuko.com,布布扣, are given as a Variable Values Assignment (VVA) 

bubuko.com,布布扣

with bubuko.com,布布扣. For instance, ( x1 = 1, x2 = 1 x3 = 0) would be a valid VVA for n = 3, resulting for the sample function above in the value bubuko.com,布布扣. The corresponding paths are shown bold in the picture.

Your task is to write a program which takes an S-tree and some VVAs and computes bubuko.com,布布扣 as described above.

Input 

The input file contains the description of several S-trees with associated VVAs which you have to process. Each description begins with a line containing a single integer nbubuko.com,布布扣, the depth of the S-tree. This is followed by a line describing the variable ordering of the S-tree. The format of that line is xi1xi2 ... xin. (There will be exactly n different space-separated strings). So, for n = 3 and the variable ordering x3x1x2, this line would look as follows:

x3 x1 x2

In the next line the distribution of 0‘s and 1‘s over the terminal nodes is given. There will be exactly 2n characters (each of which can be 0 or 1), followed by the new-line character. The characters are given in the order in which they appear in the S-tree, the first character corresponds to the leftmost terminal node of the S-tree, the last one to its rightmost terminal node.

The next line contains a single integer m, the number of VVAs, followed by m lines describing them. Each of the m lines contains exactlyn characters (each of which can be 0 or 1), followed by a new-line character. Regardless of the variable ordering of the S-tree, the first character always describes the value of x1, the second character describes the value of x2, and so on. So, the line

110

corresponds to the VVA ( x1 = 1, x2 = 1, x3 = 0).

The input is terminated by a test case starting with n = 0. This test case should not be processed.

Output 

For each S-tree, output the line `` S-Tree #j:", where j is the number of the S-tree. Then print a line that contains the value of bubuko.com,布布扣 for each of the given m VVAs, where f is the function defined by the S-tree.

Output a blank line after each test case.

Sample Input 

3
x1 x2 x3
00000111
4
000
010
111
110
3
x3 x1 x2
00010011
4
000
010
111
110
0

Sample Output 

S-Tree #1:
0011

S-Tree #2:
0011



Miguel A. Revilla
2000-02-09

就是给出n个变量,变量为1往右走,为0往左走,问到达最底层时的值是多少,数组模拟即可。

#include<stdio.h>
#include<string.h>
char ans[1005],temp[2005];
int n,o[1<<9],num;
char s[1<<9],b[1<<9];
int main()
{
    int cas=1;
    //freopen("in.txt","r",stdin);
    while(~scanf("%d",&n)&&n)
    {
        getchar();
        gets(temp);
        int len=strlen(temp);
        num=0;
        int k=1,ok=0;
        for(int i=0;i<=len;i++)
        {
            if((temp[i]>='0'&&temp[i]<='9'))
            {
                num+=num*10+temp[i]-'0';
                ok=1;
            }
            else if(ok)
            {
                o[k++]=num;
                //printf("%d\n",num);
                ok=num=0;
            }
        }
        int m;
        scanf("%s%d",s+1,&m);
        int t=0;
        while(m--)
        {
            int k=1;
            scanf("%s",b+1);
            for(int i=1;i<=n;i++)
            {
                if(b[o[i]]-'0')k=2*k+1;
                else k=2*k;
            }
            k-=(1<<n)-1;
            ans[t++]=s[k];
        }
        ans[t]='\0';
        printf("S-Tree #%d:\n%s\n\n",cas++,ans);
    }
    return 0;
}



UVA 712(二叉树模拟),布布扣,bubuko.com

UVA 712(二叉树模拟)

标签:二叉树   模拟   uva   

原文地址:http://blog.csdn.net/u013268685/article/details/27678007

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!