码迷,mamicode.com
首页 > 其他好文 > 详细

1032. Sharing (25)

时间:2015-03-03 18:41:39      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:c++   pat   

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.


Figure 1
You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:

-1

#include <iostream>
using namespace std;

int counts[100001];
int linkList[100001];
int target = -1;

int main() {
    int start1, start2;
    int n;

    for(int i=0; i<100001; i++) {
        counts[i] = 0;
        linkList[i] = -1;
    }
    cin>>start1>>start2>>n;
    if(start1 == start2) {
        printf("%05d\n", start1);
        return 0;
    }

    while(n--) {
        int value1, value2;
        char s2;
        cin>>value1>>s2>>value2;
        linkList[value1] = value2;
    }
    int i;
    for(i = start1; i!=-1; i = linkList[i]) {
        counts[i] = 1;
    }
    for(i = start2; i!=-1 && !counts[i]; i = linkList[i]) {
        counts[i] = 1;
    }
    if(i != -1) {
        printf("%05d\n", i);
    } else {
        printf("-1\n");
    }
    return 0;
}



1032. Sharing (25)

标签:c++   pat   

原文地址:http://blog.csdn.net/jason_wang1989/article/details/44040453

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!