码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1052 Tian Ji -- The Horse Racing 可恶的贪心-------也算是经典贪心题吧,对于一般人来说,不看题解,应该很难做出来吧

时间:2015-03-04 17:05:30      阅读:203      评论:0      收藏:0      [点我收藏+]

标签:hdu1052   tian ji -- the horse   贪心   

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20051    Accepted Submission(s): 5869


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian‘s. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king‘s regular, and his super beat the king‘s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

技术分享

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian‘s horses on one side, and the king‘s horses on the other. Whenever one of Tian‘s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
200 0 0
 我不生产题解————————我只是题解的搬运工。。
大牛博客:http://www.cnblogs.com/anderson0/archive/2011/05/07/2039971.html
看不懂我也没辙了.......
代码:
#include <cstdio>
#include <algorithm>
#define MAX 1010
using namespace std ;
bool cmp(const int a , const int b)
{
	return a>b ;
}
int main()
{
	int n ;
	while(~scanf("%d",&n) && n)
	{
		int t[MAX] ,k[MAX] ;
		for(int i = 0 ; i < n ; ++i)
		{
			scanf("%d",&t[i]) ;
		}
		for(int i = 0 ; i < n ; ++i)
		{
			scanf("%d",&k[i]) ;
		}
		sort(t,t+n,cmp) ;
		sort(k,k+n,cmp) ;
		int sum = 0 , win = 0 , lost = 0;
		int tail_t = n-1 , tail_k = n-1 ;
		for(int i = 0 , j = 0 ; i<=tail_t && j<=tail_k ;)
		{
			if(t[i] > k[j])
			{
				win++ ;
				++i,++j;
				continue ;
			}
			else if(t[i]<k[j])
			{
				lost++;
				--tail_t;
				++j ;
			}
			else if(t[i]==k[j])
			{
				if(t[tail_t]>k[tail_k])
				{
					win++;
					tail_t--;
					tail_k--;
				}
				else if(t[tail_t]<k[tail_k])
				{
					lost++;
					tail_t--;
					++j ;
				}
				else
				{
					if(t[tail_t]<k[j])
					{
						lost++;
					}
					tail_t--;
					++j ;
				}
			}
		}
		sum = (win-lost)*200 ;
		printf("%d\n",sum) ;
	}
	return 0 ;
}
与君共勉

hdu 1052 Tian Ji -- The Horse Racing 可恶的贪心-------也算是经典贪心题吧,对于一般人来说,不看题解,应该很难做出来吧

标签:hdu1052   tian ji -- the horse   贪心   

原文地址:http://blog.csdn.net/lionel_d/article/details/44060699

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!