码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1338 Ugly Numbers

时间:2015-03-04 22:50:29      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:poj 1338 ugly number

Ugly Numbers
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 21315   Accepted: 9520

Description

Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence 
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ... 
shows the first 10 ugly numbers. By convention, 1 is included. 
Given the integer n,write a program to find and print the n‘th ugly number. 

Input

Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.

Output

For each line, output the n’th ugly number .:Don’t deal with the line with n=0.

Sample Input

1
2
9
0

Sample Output

1
2
10

Source


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<map>

#define N 1510
#define Mod 10000007
#define lson l,mid,idx<<1
#define rson mid+1,r,idx<<1|1
#define lc idx<<1
#define rc idx<<1|1
const double EPS = 1e-11;
const double PI = acos ( -1.0 );
const double E = 2.718281828;
typedef long long ll;

const int INF = 1000010;

using namespace std;

int n;
int num[1515];

void init() {
    int n2=1,n3=1,n5=1;
    num[1]=1;
    for(int i=2; i<=N; i++) {
        num[i]=min(num[n2]*2,min(num[n3]*3,num[n5]*5));
        if(num[i]==num[n2]*2)n2++;
        if(num[i]==num[n3]*3)n3++;
        if(num[i]==num[n5]*5)n5++;
    }
}

int main() {
    init();
    while(~scanf("%d",&n)&&n)
        printf("%d\n",num[n]);
}



poj 1338 Ugly Numbers

标签:poj 1338 ugly number

原文地址:http://blog.csdn.net/acm_baihuzi/article/details/44064695

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!