码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ Friends(暴力)

时间:2015-03-09 09:24:37      阅读:199      评论:0      收藏:0      [点我收藏+]

标签:暴力

Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less than k friends in common, they will become friends in several days. Currently, there are totally n people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.

Input

There are multiple test cases.

The first lien of the input contains an integer T (about 100) indicating the number of test cases. Then T cases follow. For each case, the first line contains three integers n, m, k (1 ≤ n ≤ 100, 0 ≤ mn×(n-1)/2, 0 ≤ kn, there will be no duplicated friendship) followed by m lines showing the current friendship. The ith friendship contains two integers ui, vi (0 ≤ ui, vi < n, ui ≠ vi) indicating there is friendship between person ui and vi.

Note: The edges in test data are generated randomly.

Output

For each case, print one line containing the answer.

Sample Input

3
4 4 2
0 1
0 2
1 3
2 3
5 5 2
0 1
1 2
2 3
3 4
4 0
5 6 2
0 1
1 2
2 3
3 4
4 0
2 0

Sample Output

2
0
4

题意: n个人,有m个朋友关系(双向),如果两个人有num个以上的(含num)个公共朋友,那么他们也是朋友,问可以新加几个朋友关系


思路: 暴力,枚举i j之间有多少个公共朋友


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>


#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8

#define fre(i,a,b)  for(i = a; i <= b; i++)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define bug         pf("Hi\n")

using namespace std;

#define INF 1000000000
#define N 105

int  n,m,num,ans;
int a[N][N];

void solve()
{
	int i,j,cnt;
	ans=0;


	while(1)
	{
		  bool flag=false;


		  for(i=0;i<n;i++)
			for(j=0;j<n;j++)
			  {
			  	if(i==j) continue;
			  	if(a[i][j]) continue;

                int cnt=0;
			    for(int k=0;k<n;k++)
					if(a[i][k]&&a[k][j])
					 cnt++;

				if(cnt>=num)
				{
					a[i][j]=a[j][i]=1;
					ans++;
				    flag=true;
				}

			  }

	          if(!flag)  break;
	}
	printf("%d\n",ans);
}

int main()
{
	int i,j,t;
	ans=0;
	sf(t);
	while(t--)
	{
		sfff(n,m,num);
		mem(a,0);
		int s,e;

		while(m--)
		{
			sff(s,e);
			a[s][e]=a[e][s]=1;
		}

	  solve();

	}
	return 0;
}










ZOJ Friends(暴力)

标签:暴力

原文地址:http://blog.csdn.net/u014737310/article/details/44150463

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!