码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1469 COURSES 【二分匹配】

时间:2015-03-10 12:06:44      阅读:123      评论:0      收藏:0      [点我收藏+]

标签:二分匹配

COURSES
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 18438   Accepted: 7262

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
  • each course has a representative in the committee 

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student1 1 Student1 2 ... Student1 Count1 
Count2 Student2 1 Student2 2 ... Student2 Count2 
... 
CountP StudentP 1 StudentP 2 ... StudentP CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses ?from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

题意:每一门课可能有多个学生喜欢,定义一位学生可以代表他所喜欢的一门课(同时,这门课也就代表了这个学生),问能不能每一门课都有一个不同于其他的学生来作为代表。 其实就是一门课匹配一个学生,问能不能将所有的课都匹配。

。。。二分;

注意:用cin会超时。。。

代码:

#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>

const int M =310;

using namespace std;

bool map[110][M], vis[M], flag;
int p, n, match[M];

bool dfs(int u){
	for(int i = 1; i <= n; ++ i){
		if(!vis[i] && map[u][i]){
			vis[i] = 1;
			if(match[i] == -1||dfs(match[i])){
				match[i] = u; return true;
			}
		}
	}
	return false;
}

int main(){
	int t;
	
	//cin >> t;
	scanf("%d", &t);
	while(t --){
		//cin >> p >> n;
		scanf("%d%d", &p, &n);
		memset(map, 0, sizeof(map));
		memset(match, -1, sizeof(match));
		int m, temp;
		flag = 1;
		for(int i = 1; i <= p; ++ i){
			//cin >> m;
			scanf("%d", &m);
			if(m == 0) flag = 0;
			while(m --){
				//cin >> temp;
				scanf("%d", &temp);
				map[i][temp] = 1;
			}
		}
		if(flag == 0) {
			cout << "NO\n"; return 0;
		}
		else {
			int res = 0;
			for(int i = 1; i <= p; ++ i){
				memset(vis, 0, sizeof(vis));
				if(dfs(i)) res++;
			}
			if(res == p) cout << "YES\n";
			else cout << "NO\n";
		}
	}
	return 0;
}


poj 1469 COURSES 【二分匹配】

标签:二分匹配

原文地址:http://blog.csdn.net/shengweisong/article/details/44173159

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!