码迷,mamicode.com
首页 > 移动开发 > 详细

(hdu step 6.1.4)还是畅通工程(求让n个点联通的最小费用)

时间:2015-03-10 14:05:03      阅读:182      评论:0      收藏:0      [点我收藏+]

标签:

题目:

还是畅通工程

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 165 Accepted Submission(s): 127
 
Problem Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
 
Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
 
Output

            对每个测试用例,在1行里输出最小的公路总长度。
 
Sample Input
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0
 
Sample Output
3
5

Hint
Hint
Huge input, scanf is recommended.
 
 
Source
浙大计算机研究生复试上机考试-2006年
 
Recommend
JGShining
 


题目分析:

               使用kruscal来求最小生成树,简单题。


代码如下:

/*
 * d.cpp
 *
 *  Created on: 2015年3月10日
 *      Author: Administrator
 */


#include <iostream>
#include <cstdio>
#include <algorithm>


using namespace std;

const int maxn = 101;

struct Edge{
	int begin;
	int end;
	int weight;
}edges[maxn*maxn];//注意这里的边数应该是maxn*maxn而不是maxn。因为n个点之间应该有n*(n-1)/2条边

int father[maxn];


int find(int a){
	if(a == father[a]){
		return a;
	}

	return father[a] = find(father[a]);
}


int kruscal(int count){
	int i;

	for(i = 1 ; i < maxn ; ++i){
		father[i] = i;
	}

	int sum = 0;

	for(i = 1 ; i <= count ; ++i){
		int fa = find(edges[i].begin);
		int fb = find(edges[i].end);

		if(fa != fb){
			father[fa] = fb;
			sum += edges[i].weight;
		}
	}

	return sum;
}

bool cmp(Edge a,Edge b){
	return a.weight < b.weight;
}


int main(){
	int n;
	while(scanf("%d",&n)!=EOF,n){
		int m = (n-1)*n/2;

		int cnt = 1;
		int i;
		for(i = 1 ; i <= m ; ++i){
			scanf("%d%d%d",&edges[cnt].begin,&edges[cnt].end,&edges[cnt].weight);
			cnt++;
		}

		cnt -= 1;

		sort(edges+1,edges+1+cnt,cmp);

		printf("%d\n",kruscal(cnt));
	}

	return 0;
}






(hdu step 6.1.4)还是畅通工程(求让n个点联通的最小费用)

标签:

原文地址:http://blog.csdn.net/hjd_love_zzt/article/details/44173771

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!