码迷,mamicode.com
首页 > 其他好文 > 详细

(树形DP) hdu 1520

时间:2015-03-18 23:16:44      阅读:182      评论:0      收藏:0      [点我收藏+]

标签:

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5619    Accepted Submission(s): 2580


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests‘ conviviality ratings.
 

 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0
 

 

Output
Output should contain the maximal sum of guests‘ ratings.
 

 

Sample Input
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

 

Sample Output
5
 

 

Source
 

 

Recommend
linle   |   We have carefully selected several similar problems for you:  1561 1011 2196 1494 2242 
 

 

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
#define maxn 60000+10
vector<int> g[maxn];
int n,a[maxn],f[maxn],dp[maxn][2];
void dfs(int rt)
{
    int len=g[rt].size();
    dp[rt][1]=a[rt];
    for(int i=0;i<len;i++)
    {
        dfs(g[rt][i]);
    }
    for(int i=0;i<len;i++)
    {
        dp[rt][0]+=max(dp[g[rt][i]][0],dp[g[rt][i]][1]);
        dp[rt][1]+=dp[g[rt][i]][0];
    }
}
int main()
{
    int x,y;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            f[i]=-1;
            dp[i][0]=0,dp[i][1]=0;
            g[i].clear();
        }
        while(scanf("%d%d",&x,&y)!=EOF)
        {
            if(x==0&&y==0)
                break;
            f[x]=y;
            g[y].push_back(x);
        }
        int ret=1;
        while(f[ret]!=-1)
        {
            ret=f[ret];
        }
        dfs(ret);
        printf("%d\n",max(dp[ret][0],dp[ret][1]));
    }
    return 0;
}

  

(树形DP) hdu 1520

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4348866.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!