码迷,mamicode.com
首页 > 其他好文 > 详细

sicily 1007 To and Fro (基础题)

时间:2014-04-29 13:23:21      阅读:293      评论:0      收藏:0      [点我收藏+]

标签:sicily

链接:http://soj.me/show_problem.php?pid=1007

Description
Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is "There‘s no place like home on a snowy night" and there are five columns, Mo would write down t o i o y h p k n n e l e a i r a h s g e c o n h s e m o t n l e w x Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character `x‘ to pad the message out to make a rectangle, although he could have used any letter. Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as toioynnkpheleaigshareconhtomesnlewx Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.
Input
There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2 . ..20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.
Output
Each input set should generate one line of output, giving the original plaintext message, with no spaces.
Sample Input
mamicode.com,码迷 Copy sample input to clipboard
5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0
Sample Output
theresnoplacelikehomeonasnowynightx
thisistheeasyoneab

解题思路:

按照加密的方式还原回去就可以了;


代码如下:

// Problem#: 1007
// Submission#: 2815109
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#define MAXN 205
#define RST(N)memset(N, 0, sizeof(N))
using namespace std;

int columns;
char str[MAXN];
int len, cnt, temp, step;

void Init()
{
	scanf("%s", str);
	len = strlen(str);
	cnt = 0;
}

int main()
{
    while(~scanf("%d", &columns) && columns) {
	Init();
        for (int i=0, j=0; cnt<len; i++) {
            temp = 2*columns*i + j;
            if(temp < len) {
                putchar(str[temp]);
                cnt++;
            }else {
                i = -1;
                j++;
                continue;
            }
            temp = 2*columns*(i+1) - 1 - j;
            if (cnt < len && temp < len) {
                putchar(str[temp]);
                cnt++;
            }else {
                i = -1;
                j++;
            }
        }
        puts("");
    }
    return 0;
}                                 


sicily 1007 To and Fro (基础题)

标签:sicily

原文地址:http://blog.csdn.net/keshacookie/article/details/24666715

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!