码迷,mamicode.com
首页 > 其他好文 > 详细

POJ A Bug's Life

时间:2015-03-22 09:11:35      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:poj a bugs life

Language:
A Bug‘s Life
Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 29737   Accepted: 9729

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs‘ sexual behavior, or "Suspicious bugs found!" if Professor Hopper‘s assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
int father[2010],pre[2010];
int find(int x){
	return x==father[x]?x:father[x]=find(father[x]);
}
int main()
{
	int t,k=1,m,n,i;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;++i){
			father[i]=i;
			pre[i]=0;
		}
		int flag=0,a,b,c,d;
		for(i=0;i<m;++i){
			scanf("%d%d",&a,&b);
			if(find(a)==find(b))flag=1;
			c=pre[a];d=pre[b];
			if(c){
				c=find(c);b=find(b);
				if(c!=b)father[c]=b;
			}
			if(d){
				d=find(d);a=find(a);
				if(d!=a)father[a]=d;
			}
			pre[a]=b;pre[b]=a;
		}
		printf("Scenario #%d:\n",k++);
		if(flag)
		printf("Suspicious bugs found!\n");
		else 
		printf("No suspicious bugs found!\n");
		printf("\n");
	}
	return 0;
}


POJ A Bug's Life

标签:poj a bugs life

原文地址:http://blog.csdn.net/r1986799047/article/details/44524043

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!