码迷,mamicode.com
首页 > 其他好文 > 详细

[ACM] poj 1064 Cable master (二分查找)

时间:2014-04-29 13:44:22      阅读:360      评论:0      收藏:0      [点我收藏+]

标签:二分查找

Cable master
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 21071   Accepted: 4542

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00

Source

 

解题思路:

N条绳子,长度为别为li,要截成长度相等的K段,问切成小段的最大长度是多少。有的绳子可以不切。

也就是求一个x ,   l1/ x +l2/x +l3/x +.....=K,求最大的x。求的过程中中间值x ,如果>k也是符合题意的。要求最大的x,==k.

条件C(x)=可以得到K条长度为x的绳子

区间l=0,r等于无穷大,二分,判断是否符合c(x) C(x)=(floor(Li/x)的总和大于或等于K

代码:

#include <iostream>
#include <iomanip>
#include <stdio.h>
#include <cmath>
using namespace std;
const int maxn=10003;
const int inf=0x7fffffff;
double l[maxn];
int n,k;

bool ok(double x)//判断x是否可行
{
    int num=0;
    for(int i=0;i<n;i++)
    {
        num+=(int)(l[i]/x);
    }
    return num>=k;//被分成的段数大于等于K才可行
}

int main()
{
    cin>>n>>k;
    for(int i=0;i<n;i++)
        scanf("%lf",&l[i]);
    double l=0,r=inf;
    for(int i=0;i<100;i++)//二分,直到解的范围足够小
    {
        double mid=(l+r)/2;
        if(ok(mid))
            l=mid;
        else
            r=mid;
    }
    cout<<setiosflags(ios::fixed)<<setprecision(2)<<floor(l*100)/100;//l和r最后相等
    return 0;
}


 

[ACM] poj 1064 Cable master (二分查找)

标签:二分查找

原文地址:http://blog.csdn.net/sr_19930829/article/details/24663687

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!