码迷,mamicode.com
首页 > 其他好文 > 详细

poj3461Oulipo

时间:2015-04-03 01:31:33      阅读:111      评论:0      收藏:0      [点我收藏+]

标签:

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>

using namespace std;

char s1[11000],s2[1100000];
int next[11000];
int match[1100000];
int main()
{
    int n,i,j,k;
    cin>>n;
    getchar();
    for(i = 0;i<n;i++)
    {
        int num = 0;
        scanf("%s",s1+1);
        scanf("%s",s2+1);
        next[1] = 0;
        int l1 = strlen(s1+1);
        for(j = 2;j<l1+1;j++)
        {
            int t = next[j-1];
            while(t&&s1[j]!=s1[t+1]) t = next[t];
            if(s1[j] == s1[t+1])t++;
            next[j] = t;
        }
        int l2 = strlen(s2+1);
        match[0] = 0;
        for(j = 1;j<l2+1;j++)
        {
            int t = match[j-1];
            while(t&&s2[j]!=s1[t+1]) t = next[t];
            if(s2[j] == s1[t+1]) t++;
            match[j] = t;
            if(match[j] == l1) num++;
        }
        cout<<num<<endl;
    }
}

 

poj3461Oulipo

标签:

原文地址:http://www.cnblogs.com/wos1239/p/4388923.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!