码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3617 Best Cow Line(贪心)

时间:2014-04-29 13:48:21      阅读:358      评论:0      收藏:0      [点我收藏+]

标签:poj   acm   


Best Cow Line
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8579   Accepted: 2629

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows‘ names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he‘s finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial (‘A‘..‘Z‘) of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows (‘A‘..‘Z‘) in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

Source


这道题的思路算是比较简单吧,算是水题,但是越是简单的题越能暴露出很多问题。。(基本功不扎实啊,开始wa了好几次,后来就一直PE,开始是没看清楚题目,后来才发现自己有几处细节没掌握好),字符串的处理问题还有很多细节要注意啊!!!
把这道题的思路简单说一下吧:就是不断的比较s串的开头和末尾较小的一个字符,较小的就可以输出了,(这里有一个相等的情况),如果相等的话就要比较他们之后的字符(较小的那一个),思路并不复杂。要看清题意啊,开始的输入是一行一行的输入一个字符,后面输出的时候要80个字符要换行
下面是我的代码:
#include <stdio.h>
#include <string.h>
char s[2002];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
       for(int i=0;i<n;i++)
          scanf("\n%c",&s[i]);//这个地方参考了别人的,感觉好巧妙的,学习了,避免了输入的时候把回车保存的情况。(开始就是这个地方一直                               // wa,不能一行输入,还是要看清题意。
       int a=0,b=n-1;   
       int ans=0; //先前没注意,把这个语句定义到下面的while循环里面了,导致一直pe。。
       while(a<=b)  //首位字符进行比较
       {
           bool left=false;
           for(int i=0;a+i<=b;i++)
           {
               if(s[a+i]<s[b-i])
               {
                   left=true;
                   break;
               }
               else if(s[a+i]>s[b-i])
               {
                   left=false;
                   break;
               }
           }
               if(left) printf("%c",s[a++]);
               else printf("%c",s[b--]);
                ans++;
               if(ans==80){  //这个地方我测试了一下  如果写成下面的样子的话,时间就是16ms
                printf("\n");
                ans=0;
               }
               /*if(ans==80)//这样写就是16ms,上面就是0ms,不知道是判题的问题,还是本身就节约时间,不解
               {
                printf("\n");
                ans=0;
               }*/
           }
       printf("\n");
    }
    return 0;
}
一个这样的题目都还ac我好久啊,基础还是不扎实,自己还是要加强训练!!!加油!!

poj 3617 Best Cow Line(贪心)

标签:poj   acm   

原文地址:http://blog.csdn.net/whjkm/article/details/24635219

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!