码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4739Zhuge Liang's Mines(简单dfs,需要注意重点)

时间:2014-04-29 13:38:22      阅读:368      评论:0      收藏:0      [点我收藏+]

标签:dfs

Zhuge Liang‘s Mines

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1166    Accepted Submission(s): 505


Problem Description
In the ancient three kingdom period, Zhuge Liang was the most famous and smartest military leader. His enemy was Shima Yi, who always looked stupid when fighting against Zhuge Liang. But it was Shima Yi who laughed to the end. 

Once, Zhuge Liang sent the arrogant Ma Shu to defend Jie Ting, a very important fortress. Because Ma Shu is the son of Zhuge Liang‘s good friend Ma liang, even Liu Bei, the Ex. king, had warned Zhuge Liang that Ma Shu was always bragging and couldn‘t be used, Zhuge Liang wouldn‘t listen. Shima Yi defeated Ma Shu and took Jie Ting. Zhuge Liang had to kill Ma Shu and retreated. To avoid Shima Yi‘s chasing, Zhuge Liang put some mines on the only road. Zhuge Liang deployed the mines in a Bagua pattern which made the mines very hard to remove. If you try to remove a single mine, no matter what you do ,it will explode. Ma Shu‘s son betrayed Zhuge Liang , he found Shima Yi, and told Shima Yi the only way to remove the mines: If you remove four mines which form the four vertexes of a square at the same time, the removal will be success. In fact, Shima Yi was not stupid. He removed as many mines as possible. Can you figure out how many mines he removed at that time?

The mine field can be considered as a the Cartesian coordinate system. Every mine had its coordinates. To simplify the problem, please only consider the squares which are parallel to the coordinate axes.
 

Input
There are no more than 15 test cases.
In each test case:

The first line is an integer N, meaning that there are N mines( 0 < N <= 20 ).

Next N lines describes the coordinates of N mines. Each line contains two integers X and Y, meaning that there is a mine at position (X,Y). ( 0 <= X,Y <= 100)

The input ends with N = -1.
 

Output
For each test case ,print the maximum number of mines Shima Yi removed in a line.
 

Sample Input
3 1 1 0 0 2 2 8 0 0 1 0 2 0 0 1 1 1 2 1 10 1 10 0 -1
 

Sample Output
0 4
 

Source
 

题目大意:给你一些点,最多二十个,让你找用这些点弄出正方形的个数,输出个数*4。

    不过需要注意的是有重点。

    还是有些细节没考虑到,WA了很多,T了几次。。


AC代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

int ans,n;
int cnt[105][105];

struct node
{
    int x;
    int y;
}nod[25];

int cmp(node p1,node p2)
{
    if(p1.x<p2.x) return 1;
    if(p1.x==p2.x&&p1.y<p2.y) return 1;
    return 0;
}

void dfs(int cur,int score)
{
    if(score>ans) ans=score;
    if(cur>=n) return;
    if(ans>=n-cur+score) return;

    int i;
    int cx,cy,px,py;
    cx=nod[cur].x,cy=nod[cur].y;

    if(cnt[cx][cy]<=0)
    {
        dfs(cur+1,score);
        return;
    }
    for(i=cur+1;i<n;i++)
    {
        px=nod[i].x,py=nod[i].y;
        if(px>cx) break;
        if(py==cy) continue;
        int len=py-cy;
        if(cnt[cx][cy]&&cnt[cx][cy+len]&&cnt[cx+len][cy]&&cnt[cx+len][cy+len])
        {
            cnt[cx][cy]--,cnt[cx][cy+len]--;
            cnt[cx+len][cy]--,cnt[cx+len][cy+len]--;
            dfs(cur+1,score+4);
            cnt[cx][cy]++,cnt[cx][cy+len]++;
            cnt[cx+len][cy]++,cnt[cx+len][cy+len]++;
        }
    }
    dfs(cur+1,score);
}

int main()
{
    int i;
    while(scanf("%d",&n))
    {
        if(n==-1) break;
        memset(cnt,0,sizeof(cnt));

        for(i=0;i<n;i++)
        {
            scanf("%d%d",&nod[i].x,&nod[i].y);
            cnt[nod[i].x][nod[i].y]++;
        }
        sort(nod,nod+n,cmp);

        ans=0;
        dfs(0,0);
        cout<<ans<<endl;
    }
    return 0;
}



hdu 4739Zhuge Liang's Mines(简单dfs,需要注意重点)

标签:dfs

原文地址:http://blog.csdn.net/coraline_m/article/details/24634943

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!