码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1524 A Chess Game(SG函数)

时间:2015-04-09 19:53:07      阅读:116      评论:0      收藏:0      [点我收藏+]

标签:acm   博弈   

Problem Description:

Let‘s design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again.
Do you want to challenge me? Just write your program to show your qualification!

Input:

Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.

Output:

There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.

Sample Input:

4
2 1 2
0
1 3
0
1 0
2 0 2
0

4
1 1
1 2
0
0
2 0 1
2 1 1
3 0 1 3
0

Sample Output:

WIN
WIN
WIN
LOSE
WIN

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <cmath>
#include <vector>
#include <map>
#include <set>
using namespace std;
const int MAXN = 1000 + 10;
vector<int>G[MAXN];
int SG[MAXN];
int mex(int x)
{
    if(SG[x] != -1)
        return SG[x];
    bool vis[MAXN];
    memset(vis, 0, sizeof(vis));
    int sz = G[x].size();
    for(int i=0;i<sz;i++)
        vis[mex(G[x][i])] = 1;
    for(int i=0;;i++) if(!vis[i])
    {
        SG[x] = i;
        break;
    }
    return SG[x];
}
int main()
{
    int n;
    while(cin>>n)
    {
        memset(SG, -1, sizeof(SG));
        for(int i=0;i<n;i++) G[i].clear();
        for(int i=0;i<n;i++)
        {
            int m;
            cin>>m;
            while(m--)
            {
                int x;
                cin>>x;
                G[i].push_back(x);
            }
        }
        int Q;
        while(cin>>Q)
        {
            if(Q == 0)
                break;
            int ans = 0;
            while(Q--)
            {
                int x;
                cin>>x;
                ans ^= mex(x);
            }
            if(ans) puts("WIN");
            else puts("LOSE");
        }
    }
    return 0;
}


HDU 1524 A Chess Game(SG函数)

标签:acm   博弈   

原文地址:http://blog.csdn.net/moguxiaozhe/article/details/44963557

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!