码迷,mamicode.com
首页 > 其他好文 > 详细

Lost Cows

时间:2015-04-12 09:09:45      阅读:99      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9669   Accepted: 6228

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood ‘watering hole‘ and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he‘s not very good at observing problems. Instead of writing down each cow‘s brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.

Input

* Line 1: A single integer, N

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

跟fzu月赛的一道题很像,当时是从前往后找,现在应该是从后往前找,第i个数应是原顺序序列中的第rcd[i]+1小的数
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
#include<stack>
using namespace std;
const int inf=1<<25;
int n;
int rcd[10000];
void in_put()
{
    cin>>n;
    for(int i=2;i<=n;++i)
    cin>>rcd[i];
}
void solve()
{
    int i,j;
    stack<int>s;
    int num[10000];
    for(i=0;i<=n;++i) num[i]=i;
    for(i=n;i>=2;i--){//从后往前找1 2 3 4...n中的第n小的数
       int cnt=0;
       for(j=1;j<=n;++j){
       if(num[j]!=inf) cnt++;
       if(cnt==rcd[i]+1) break;
       }
        s.push(num[j]);
        num[j]=inf;//找到一个后标记为大值inf
    }
    for(int i=1;i<=n;++i) if(num[i]!=inf) {s.push(i);break;}//把第一个也压入栈
    while(!s.empty()){
        cout<<s.top()<<endl;
        s.pop();
    }
}
int main()
{
    in_put();
    solve();
    return 0;
}

 

Lost Cows

标签:

原文地址:http://www.cnblogs.com/orchidzjl/p/4419023.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!