码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 HDU ACM 1212 Big Number

时间:2015-04-16 17:46:09      阅读:100      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   杭电   算法   编程   

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5606    Accepted Submission(s): 3903


Problem Description
As we know, Big Number is always troublesome. But it‘s really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 

Output
For each test case, you have to ouput the result of A mod B.
 

Sample Input
2 3 12 7 152455856554521 3250
 

Sample Output
2 5 1521
 

Author
Ignatius.L
 

Source
 
这是在网上搜到的 应该记住的结论:
A*B % C = (A%C * B%C)%C
(A+B)%C = (A%C + B%C)%C
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    char ls[1004];int n;
    while(scanf("%s%d",ls,&n)!=EOF)
    {
        int sum=0;
        for(int i=0;i<strlen(ls);i++)
        {
            sum=(sum*10+(ls[i]-'0')%n)%n;

        }
        cout<<sum<<endl;
    }
    return 0;
}

杭电 HDU ACM 1212 Big Number

标签:acm   c++   杭电   算法   编程   

原文地址:http://blog.csdn.net/lsgqjh/article/details/45076855

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!