码迷,mamicode.com
首页 > 其他好文 > 详细

POJ-2318

时间:2015-04-17 13:08:24      阅读:124      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 11293   Accepted: 5439

Description

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John‘s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.
技术分享
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

Source

/**
          题意:给一个区域的左上和右上坐标,然后给出区域中的n条边,然后,给出m个玩具的坐标;
                    求每个玩具都在那个区域
          做法:计算几何
**/
#include <iostream>
#include<cmath>
#include<algorithm>
#include<string.h>
#include<stdio.h>
#define maxn 5000 + 10
using namespace std;
int n,m;
int mmap[maxn];
const double eps = 1e-8;
const  double PI = acos(-1.0);
struct Point
{
    double x;
    double y;
    Point() {}
    Point(double _x,double _y)
    {
        x = _x;
        y = _y;
    }
    Point operator - (const Point &b) const
    {
        return Point(x - b.x,y - b.y);
    }
    double operator ^(const Point &b) const
    {
        return x*b.y - y*b.x;
    }
    double  operator *(const Point &b) const
    {
        return x*b.x + y*b.y;
    }
};
struct Line
{
    Point s;
    Point e;
    Line() {}
    Line(Point _s,Point _e)
    {
        s = _s;
        e = _e;
    }
} line[maxn];
int mul(Point a,Point b,Point c)
{
    return (b - a) ^(c - a);
}
int main()
{
#ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
#endif // ONLINE_JUDGE
    int x1,y1,x2,y2;
    while(~scanf("%d",&n))
    {
        if(n == 0) break;
        memset(mmap,0,sizeof(mmap));
        scanf("%d %d %d %d %d",&m,&x1,&y1,&x2,&y2);
        int u,l;
        for(int i=0; i<n; i++)
        {
            scanf("%d %d",&u,&l);
            line[i] = Line(Point(u,y1),Point(l,y2));
        }
        line[n] = Line(Point(x2,y1),Point(x2,y2));
        int x,y;
        for(int i=0; i<m; i++)
        {
            scanf("%d %d",&x,&y);
            Point pp = Point(x,y);
            int left = 0;
            int right = n;
            int tmp = 0;
            while(left <= right)
            {
                int mid = (left + right) >>1;
                if(mul(pp,line[mid].s,line[mid].e)<0)
                {
                    tmp = mid;
                    right = mid-1;
                }
                else left = mid+1;
            }
            mmap[tmp] ++;
        }
        for(int i=0; i<=n; i++)
        {
            printf("%d: %d\n",i,mmap[i]);
        }
        printf("\n");
    }
}

 

POJ-2318

标签:

原文地址:http://www.cnblogs.com/chenyang920/p/4434404.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!