码迷,mamicode.com
首页 > 其他好文 > 详细

pku3090 Visible Lattice Points:人生第一个欧拉函数

时间:2015-04-21 09:51:49      阅读:138      评论:0      收藏:0      [点我收藏+]

标签:欧拉函数

这是一道很有纪念价值的题目!

Visible Lattice Points
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5812   Accepted: 3434

Description

A lattice point (xy) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (xy) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (xy) with 0 ≤ xy ≤ 5 with lines from the origin to the visible points.

技术分享

Write a program which, given a value for the size, N, computes the number of visible points (xy) with 0 ≤ xy ≤ N.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4
2
4
5
231

Sample Output

1 2 5
2 4 13
3 5 21
4 231 32549

Source

既然这是一道有价值的题目,我就不给翻译了

直接上代码!

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#define __________ 1100
#define ___________ 0
#define ____________ 1
#define _____________ 2
#define ______________ 3
using namespace std;
int __[__________], _[__________], _______, ____;
bool ___[__________];
void getprime (){
	memset ( ___, false, sizeof (___) );
	memset ( _, ___________, sizeof (_) );
	____ = ___________;
	int _____, ______;
	for ( _____ = _____________; _____ <= _______; _____ ++ ){
		if ( ___[_____] == false ){
			__[++____] = _____;
			_[_____] = _____-____________;
		}
		for ( ______ = ____________; ______ <= ____ && _____*__[______] <= _______; ______ ++ ){
			___[_____*__[______]] = true;
			if ( _____ % __[______] == ___________ ){
				_[_____*__[______]] = _[_____] * __[______];
			}
			else {
				_[_____*__[______]] = _[_____] * ( __[______] - ____________ );
			}
		}
	}
	for ( _____ = ____________; _____ <= _______; _____ ++ ) _[_____] += _[_____-____________];
}
int main (){
	int _____, ______, ________, _________;
	_______ = __________;
	getprime ();
	scanf ( "%d", &________ ); _________ = ___________;
	while ( ________ -- ){
		scanf ( "%d", &_______ );
		printf ( "%d %d %d\n", ++_________, _______, _[_______]*_____________+______________ );
	}
	return ___________;
}
人生第一个欧拉函数!代码极其精致!各位看了记得给我点赞!我的代码风格可是我们小学最好的!

我也不多说什么,自己看代码吧!


pku3090 Visible Lattice Points:人生第一个欧拉函数

标签:欧拉函数

原文地址:http://blog.csdn.net/ra1nbow_chan/article/details/45155839

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!