码迷,mamicode.com
首页 > 其他好文 > 详细

Number Sequence

时间:2015-05-08 22:08:18      阅读:144      评论:0      收藏:0      [点我收藏+]

标签:杭电1005   number-seq   

Number Sequence

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

代码:

#include<iostream>
using namespace std;

#define BUFFSIZE 200

int main(void)
{
    int A, B, i;
    long  n;
    int buf[BUFFSIZE];
    while (cin >> A >> B >> n)
    {
        if (A == 0 || B == 0 || n == 0)
        {
            break;
        }
        buf[1] = buf[2] = 1;
        bool flag = false;
        for (i = 3; i < BUFFSIZE; i++)
        {
            buf[i] = (A*buf[i-1] + B*buf[i - 2]) % 7;
            if (buf[i] == 1 && buf[i - 1] == 1)
            {
                break;
            }
            if (buf[i] == 0 && buf[i - 1] == 0)
            {
                flag = true;
                break;
            }
        }
        if (flag)
        {
            cout << 0 << endl;
            continue;
        }
        if (i > n)
        {
            cout << buf[n] << endl;
            continue;
        }
        i -= 2;
        n %= i;
        if (n == 0) n = i;
        cout << buf[n] << endl;
    }
    return 0;
}

这个题我是觉得有点奇葩,如果把for (i = 3; i < BUFFSIZE; i++)修改为for (i = 3; i <= n; i++) ,运行起来就会 RuntimeError。
这道题我刚刚开始用递归,类斐波拉契数列来算,都是 RuntimeError,或者是Time Limit Exceeded**

Number Sequence

标签:杭电1005   number-seq   

原文地址:http://blog.csdn.net/u013647382/article/details/45584665

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!