码迷,mamicode.com
首页 > 其他好文 > 详细

NYOJ 293 Sticks 【深搜】+【剪枝】

时间:2014-06-15 12:18:43      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:nyoj 293

这是一道让人泪奔的题,它深刻的说明了什么是剪枝,哪怕是再小的一个细节,一旦递归规模增大都会引发巨大的时间消耗,真是神题~

Sticks

时间限制:3000 ms  |  内存限制:65535 KB
难度:5
描述
George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.
输入
The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.
输出
The output should contains the smallest possible length of original sticks, one per line.
样例输入
9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0
样例输出
6
5

#include <cstdio>
#include <algorithm>
using std::sort;
int stick[66], n, sum, len, ok, temp;
bool vis[66];

bool cmp(int a, int b){
	return a > b;
}

bool DFS(int k, int left, int total){ //第k个木棍,剩下的匹配长度,剩下的总长度
	if(left == 0){ //已经匹配完一份
		total -= len;
		if(!total) return true;
		
		int i = 1;
		while(vis[i]) ++i;
		vis[i] = 1; //cut, 找到的第一根肯定要用,此时就给他用掉,如果不用会TLE
		if(DFS(i + 1, len - stick[i], total)) return true;
		vis[i] = 0;
		return false;
	}
	
	for(int i = k; i < n; ++i){
		if(i > 0 && stick[i] == stick[i-1] && !vis[i-1]) //cut,若前一个相同长度的匹配失效,则当前不需要深搜下去
			continue;
		if(!vis[i] && left >= stick[i]){			
			vis[i] = 1; left -= stick[i]; 
			if(DFS(i + 1, left, total)) return true;
			vis[i] = 0; 
			if(!left) return false; //cut
			left += stick[i];
		}
	}
	return false;
}

int main(){
	while(scanf("%d", &n), n){
		sum = ok = 0;
		for(int i = 0; i < n; ++i){
			scanf("%d", stick + i);
			vis[i] = 0; sum += stick[i];
		}
		sort(stick, stick + n, cmp);
		temp = sum / 2; len = stick[0]; //剪枝1
		vis[0] = 1;
		while(len <= temp){
			if(sum % len == 0 && DFS(1, len - stick[0], sum)){ //剪枝2
				printf("%d\n", len); 
				ok = 1; break;
			}
			++len;
		}
		if(!ok) printf("%d\n", sum);
	}
	return 0;
}


NYOJ 293 Sticks 【深搜】+【剪枝】,布布扣,bubuko.com

NYOJ 293 Sticks 【深搜】+【剪枝】

标签:nyoj 293

原文地址:http://blog.csdn.net/chang_mu/article/details/30766491

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!