码迷,mamicode.com
首页 > 其他好文 > 详细

kyeremal-poj1113-Wall-凸包

时间:2015-05-25 10:07:39      阅读:147      评论:0      收藏:0      [点我收藏+]

标签:

poj1113-Wall

Wall
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 31394   Accepted: 10610

Description

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King‘s castle. The King was so greedy, that he would not listen to his Architect‘s proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall. 
技术分享

Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King‘s requirements. 

The task is somewhat simplified by the fact, that the King‘s castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle‘s vertices in feet.

Input

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King‘s castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle. 

Next N lines describe coordinates of castle‘s vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

Output

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King‘s requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

Sample Input

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

Sample Output

1628

Hint

结果四舍五入就可以了

Source



题意:给定N个点,求最小的图形,使得所有点均在凸多边形内,且任一点到凸多边形的距离不小于L,求图形最小的周长.


首先想到凸包.

但是有距离不小于L的限制,那么考虑以每个点作一个半径为L的圆.

那么最终图形一定包含所有的N个圆.

最终图形包括直线和弧.

直线便与圆相切,切对应直线的∑长度=凸包周长,

接下来考虑∑弧长,每一段弧都对应一个转折点.

考虑圆上的一点i,经过每一段弧后回到原来的位置.

即∑弧长=以L为半径的圆的周长.

那么最终答案 = 凸包周长 + 2×π×R.


code:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <algorithm>

using namespace std;

#define rep(i, l, r) for (int i = l; i <= r; i++)
#define REP(i, l, r) for (int i = l; i >= r; i--)
#define PI (3.14159265358979323846264)
#define INF 19971228
#define MAXN 1010

int n, L, stack[MAXN], top;
struct point {int x, y;} a[MAXN], p0;

point operator -(point a, point b) {a.x = a.x - b.x, a.y = a.y - b.y; return a;}
int operator ^(point a, point b) {return a.x*b.y - a.y*b.x;}
int operator *(point a, point b) {a = a - p0, b = b - p0; return a^b;}

inline int sqr(int x) {return x*x;}
inline double dist(point a, point b) {return sqrt(sqr(a.y-b.y) + sqr(a.x-b.x));}
inline bool cmp(point a, point b) {
    if (a*b > 0) return 1;
    else if (a*b == 0 && dist(a, p0) < dist(b, p0)) return 1;
    return 0;
}

inline bool left(point a, point b, point c) {
    point v1, v2;
    v1.x = b.x - a.x, v1.y = b.y - a.y;
    v2.x = c.x - b.x, v2.y = c.y - b.y;
    return (v1^v2) > 0;
}

inline void graham() {
    a[++n] = a[1];
    top = 0;
    stack[++top] = 1;
    stack[++top] = 2;
    stack[++top] = 3;
    rep(i, 4, n) {
	while (!left(a[stack[top-1]], a[stack[top]], a[i])) top--;
	stack[++top] = i;
    }
}

int main() {
    cin >> n >> L;
    int minx = INF, miny = INF, k;
    rep(i, 1, n) {
	scanf("%d%d", &a[i].x, &a[i].y);
	if (a[i].x < minx || (a[i].x == minx && a[i].y < miny)) minx = a[i].x, miny = a[i].y, k = i;
    }
    p0.x = minx, p0.y = miny;
    sort(a+1, a+1+n, cmp);
    graham();
    double ans = 0;
    rep(i, 2, top) ans += dist(a[stack[i-1]], a[stack[i]]);
    ans += 2 * PI * L;
    printf("%d\n", int(ans + 0.5));

    return 0;
}


kyeremal-poj1113-Wall-凸包

标签:

原文地址:http://blog.csdn.net/kyeremal/article/details/45957587

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!