码迷,mamicode.com
首页 > 其他好文 > 详细

HDU ACM 1272 小希的迷宫

时间:2015-05-25 22:32:48      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   杭电   算法   编程   

小希的迷宫

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31911    Accepted Submission(s): 9850


Problem Description
上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。
技术分享
 

Input
输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。
 

Output
对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。
 

Sample Input
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 

Sample Output
Yes Yes No
 

Author
Gardon
 

Source
 
操蛋,爆栈N次!并查集中要注意不一定非得用路径压缩!!结果写了好几个版本,原来是并查集函数的错误,其实这些个版本改动那一处全都能ac。首先发现可以利用并查集判断无向图回路,其次如果不存在回路,在它是连通图的情况下,如果是一棵树,那么必然有结点数=边数+1;注意前后逻辑。
 
#include<set>
#include<map>
#include<iostream>
#include<string.h>
using namespace std;
const int M=500004;
int F[M];
int cnt[M];
int Find(int x)
{
    int r=x;
    while(F[r]!=r)
        r=F[r];
    int k=x;
    while(k!=r)
    {
        int t=F[k];
        F[k]=r;
        k=t;
    }
    return r;
}

bool Is_same(int x,int y)
{
    return Find(x)==Find(y);
}

void union_set(int x , int y)
{
    int tx=Find(x);
    int ty=Find(y);
    if(tx!=ty)
    {
        F[tx]=ty;
    }

}

int main()
{
    int flag1=0;
    int a,b;
loop:
    for(int j=0; j<M; j++)
        F[j]=j;
    int aa=0,count=0;
    set<int>dict;
    int flag2=0;
    memset(cnt,0,sizeof(cnt));
    int MM=-1,MII=9999999;
    cin>>a>>b;
    if((a==-1)&&(b==-1))
        return 0;
    else if(a==0&&b==0)
    {
        cout<<"Yes"<<endl;
        goto loop;
    }
    else
    {
        if(!cnt[a])
            aa++;
        if(!cnt[b])
            aa++;
        count++;
        cnt[a]=1;
        cnt[b]=1;
        if(a>MM)
            MM=a;
        if(b>MM)
            MM=b;
        if(a<MII)
            MII=a;
        if(b<MII)
            MII=b;
        union_set(a,b);
    }

    while(cin>>a>>b,a+b)
    {
        if(!cnt[a])
            aa++;
        if(!cnt[b])
            aa++;
        count++;
        cnt[a]=1;
        cnt[b]=1;
        if(a>MM)
            MM=a;
        if(b>MM)
            MM=b;
        if(a<MII)
            MII=a;
        if(b<MII)
            MII=b;

        union_set(a,b);
    }



    for(int t=MII; t<=MM; t++)
    {
        if(cnt[t]==1)
            dict.insert(Find(t));
    }

    if(dict.size()!=1)
        flag2=1;

    if(!flag2&&aa==count+1)
        cout<<"Yes"<<endl;
    else
        cout<<"No"<<endl;

    dict.clear();

    goto loop;
    return 0;
}


或着:
#include<set>
#include<iostream>
#include<string.h>
using namespace std;
const int M=100004;
int F[M];

int Find(int x)
{
    int r=x;
    while(F[r]!=r)
        r=F[r];
    int k=x;
    while(k!=r)
    {
        int t=F[k];
        F[k]=r;
        k=t;
    }
    return r;
}

bool Is_same(int x,int y)
{
    return Find(x)==Find(y);
}

void union_set(int x , int y)
{
    int tx=Find(x);
    int ty=Find(y);
    if(tx!=ty)
    {
        F[tx]=ty;
    }
}

int main()
{
    set<int>dict;
    int flag1=0;
    for(int j=0; j<M; j++)
        F[j]=j;

    int a,b,flag=0;
loop:
    while(cin>>a>>b,a+b)
    {
        flag=1;
        if((a==-1)&&(b==-1))
            return 0;

        dict.insert(a);
        dict.insert(b);

        if(Is_same(a,b))
            flag1=1;
        union_set(a,b);
    }
    if(!flag)
    {
        cout<<"Yes"<<endl;
        goto loop;
    }
    int flag2=0;
    set<int> ::iterator it=dict.begin();
    int f0=Find(*it);
    it++;
    for(; it!=dict.end(); it++)
    {
        if(Find(*it)!=f0)
            flag2=1;
    }
    //cout<<"flag="<<flag1<<" flag2="<<flag2<<endl;
    if(flag1||flag2)
        cout<<"No"<<endl;
    else
        cout<<"Yes"<<endl;
    dict.clear();
    for(int j=0; j<=M; j++)
        F[j]=j;
    flag=0;
    goto loop;
    return 0;
}

 

HDU ACM 1272 小希的迷宫

标签:acm   c++   杭电   算法   编程   

原文地址:http://blog.csdn.net/lsgqjh/article/details/45973721

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!