码迷,mamicode.com
首页 > 其他好文 > 详细

poj1258 最小生成树 普林姆

时间:2014-07-22 23:04:15      阅读:229      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   os   strong   

Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 36780   Accepted: 14825

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28


单纯的求最小生成树普林斯算法,要说是水题,却不是菜鸟都能轻松过的。且学且刷~~

#include<iostream>
#include<cstring> 
using namespace std;
int a[101][101],d[101],used[101],n;
int main(){
	while(cin>>n&&n>=3&&n<=100){
		memset(d,0,sizeof(d));
		memset(a,0,sizeof(a));
		memset(used,0,sizeof(used));  
		int sum=0;
		used[0]=1;
		d[0]=999999;  //尽可能大,不要错写成0
		for(int i=0;i<n;i++)
		  for(int j=0;j<n;j++)
		    cin>>a[i][j];
		for(int k=1;k<n;k++)d[k]=a[0][k];//数组d用于动态记录点到最小生成树的距离
		for(int i=0;i<n-1;i++){
			int flag=0;
			for(int j=1;j<n;j++)
			  if(d[j]<d[flag]&&!used[j]) flag=j;//遍历寻找树外到最小树距离最小的点
			used[flag]=1;
			sum+=d[flag];
			for(int j=1;j<n;j++) //节点flag加入最小生成树,更新数据
			  if(!used[j])
			   d[j]=min(d[j],a[j][flag]);
		}
		cout<<sum<<endl;
	}
	return 0;
}


poj1258 最小生成树 普林姆,码迷,mamicode.com

poj1258 最小生成树 普林姆

标签:des   style   blog   color   os   strong   

原文地址:http://blog.csdn.net/lindonglian/article/details/24736489

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!