码迷,mamicode.com
首页 > 其他好文 > 详细

[ACMcoder] Number Sequence

时间:2015-05-26 21:31:08      阅读:131      评论:0      收藏:0      [点我收藏+]

标签:acmcoder

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3
1 2 10
0 0 0

Sample Output
2
5

解题思路

利用数组的循环规律解题,周期为i-2。

实现代码

#include <iostream>
using namespace std;

int main()
{
    int A, B, n;
    int f[53];
    while (cin>>A>>B>>n)
    {
        if (A == 0 && B == 0 && n == 0)
        {
            break;
        }
        f[1] = 1; f[2] = 1;
        int i, j, z;
        for (i = 3; i <= 52; i++)
        {
            f[i] = (A * f[i-1] + B * f[i-2]) % 7;
            if (f[i] == 1 && f[i-1] == 1)
            {
                break;
            }
        }
        i -= 2;
        n %= i;
        if (n == 0)
        {
            cout<<f[i]<<endl;
        }
        else
        {
            cout<<f[n]<<endl;
        }
    }
};

[ACMcoder] Number Sequence

标签:acmcoder

原文地址:http://blog.csdn.net/foreverling/article/details/45156189

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!