码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3258- River Hopscotch(二分求最小值最大)

时间:2015-06-01 16:40:44      阅读:271      评论:0      收藏:0      [点我收藏+]

标签:二分   数论   

River Hopscotch
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up torocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: LN, and M
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

题意:数轴上有n个石子(但一共有n+2个,因为开头和结尾各有一个记为0,n+1),第i个石头的坐标为Di,现在要从0跳到L,每次条都从一个石子跳到相邻的下一个石子。现在FJ允许你移走M个石子,问移走这M个石子后,相邻两个石子距离的最小值的最大值是多少,因为移动有很多种方法,每一种有一个最小值距离,这些最小值里面的最大值。

思路:二分距离,当你已经模拟了一个距离值后,需要对原有的石子进行移动,因为你模拟的最小间距,所以如果两个相邻石子距离比他小,那么就应该移除后一个石子,记录移除石子+1,然后进行下次计算,直到有个点和开始的这个点距离大于最小值(开始的点不一定是起点),记得此时更改起始点为满足时的后一个点,进行下次比较,最后比较移除的石子和实际的比较,再改变高低点的位置。


#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;
const double eps=1e-8;
const double pi= acos(-1.0);
const int maxn=50010;
int L,n,m;
int a[maxn];
int judge(int mid)
{
    int cnt=0;
    int j=0;
    for(int i=1;i<=n+1;i++){
        if(a[i]-a[j]<=mid)//如果相邻两节点的距离小于此时的假设最小值,则删除该节点,记录+1;
            cnt++;//记录移动石子的数目
        else//否则则更换起始节点的候选情况为节点a[i]
            j=i;
    }
    if(cnt>m)
        return 0;
    else
        return 1;
}

int main()
{
    while(~scanf("%d %d %d",&L,&n,&m)){
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        a[0]=0;//起点
        a[n+1]=L;//终点
        int low=0,high=L;
        int mid;
        int ans;
        sort(a,a+n+2);
        while(low<=high){
            mid=(low+high)>>1;//对最大跳和最小跳的距离折中,二分查找mid相对于最优解是偏大还是偏小  
                              //假设mid是移除m个石头后的最短距离 
            if(judge(mid)==1){
                low=mid+1;
            }
            else
                high=mid-1;
        }
        printf("%d\n",low);

    }
    return 0;
}


POJ 3258- River Hopscotch(二分求最小值最大)

标签:二分   数论   

原文地址:http://blog.csdn.net/u013486414/article/details/46312001

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!