码迷,mamicode.com
首页 > 其他好文 > 详细

[POJ 2376] Cleaning Shifts

时间:2015-06-03 00:38:58      阅读:149      评论:0      收藏:0      [点我收藏+]

标签:

Cleaning Shifts
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12874   Accepted: 3331

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

Source

 
区间覆盖问题、
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdio>
using namespace std;
#define N 25010

struct P
{
    double x1,x2;
    bool operator < (const P &t)const
    {
        if(x1!=t.x1) return x1<t.x1;
        return x2<t.x2;
    }
}p[N];
int main()
{
    int n,l,i;
    while(scanf("%d%d",&n,&l)!=EOF)
    {
        for(i=1;i<=n;i++) scanf("%lf%lf",&p[i].x1,&p[i].x2);
        sort(p+1,p+n+1);

        i=1;
        bool flag=1;
        int cnt=0;
        double tmp=0;
        while(i<=n && tmp<l) //tmp指当前起点
        {
            if(p[i].x1>tmp+1)
            {
                flag=0;
                break;
            }
            double mx=tmp;
            while(i<=n && p[i].x1<=tmp+1)
            {
                mx=max(mx,p[i].x2);
                i++;
            }
            tmp=mx;
            cnt++;
        }
        if(tmp<l) flag=0;
        if(flag) printf("%d\n",cnt);
        else printf("-1\n");
    }
    return 0;
}

[POJ 2376] Cleaning Shifts

标签:

原文地址:http://www.cnblogs.com/hate13/p/4548057.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!