码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2492 A Bug's Life

时间:2015-06-04 22:28:59      阅读:118      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 30184   Accepted: 9886

Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs‘ sexual behavior, or "Suspicious bugs found!" if Professor Hopper‘s assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.
 
和 POJ1703 一样
CODE:
#include <iostream>
#include <cstdio>
#include <cstring>
#define REP(i, s, n) for(int i = s; i <= n; i ++)
#define REP_(i, s, n) for(int i = n; i >= s; i --)
#define MAX_N 2000 + 10

using namespace std;

int n, q, F[MAX_N];
int D[MAX_N];

int find(int x){
    if(x == F[x]) return x;
    return F[x] = find(F[x]);
}
void Union(int x,int y){
    x = find(x), y = find(y);
    if(x == y) return;
    F[y] = x;
}

int main(){
    int T; scanf("%d", &T);
    REP(k, 1, T){
        scanf("%d%d", &n, &q);
        REP(i, 1, n) F[i] = i, D[i] = 0;
        int x, y; bool ok = 1;
        while(q --){
            scanf("%d%d", &x, &y);
            if(find(x) != find(y)){
                if(!D[x] && !D[y]) D[x] = y, D[y] = x;
                else if(!D[x]) D[x] = y, Union(x, D[y]);
                else if(!D[y]) D[y] = x, Union(y, D[x]);
                else Union(x, D[y]), Union(y, D[x]);
            }
            else ok = 0;
        }
        printf("Scenario #%d:\n", k);
        if(!ok) printf("Suspicious bugs found!\n\n");
        else printf("No suspicious bugs found!\n\n");
    }
    return 0;
}

 

POJ 2492 A Bug's Life

标签:

原文地址:http://www.cnblogs.com/ALXPCUN/p/4552924.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!