码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3264 Balanced Lineup

时间:2014-06-28 09:32:17      阅读:200      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   get   os   

Description

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

简单的线段树题目,就是线段树求最大值与最小最,然后最大与最小相减,都不用更新,在建树的时候顺便更新一下就可以了,简单的不能再简单了
#include<map>
#include<set>
#include<stack>
#include<queue>
#include<cmath>
#include<vector>
#include<cstdio>
#include<string>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#define  inf 0x0f0f0f0f

using namespace std;
const int maxn=50000+10;

struct node
{
     int L,R,maxx,minx;
}tree[maxn*4];
int a[maxn];

void build(int c,int x,int y)
{
     tree[c].L=x; tree[c].R=y;
     if (x==y)
     {
          tree[c].minx=a[x];
          tree[c].maxx=a[x];
          return;
     }
     int mid=x+(y-x)/2;
     build(c*2,x,mid);
     build(c*2+1,mid+1,y);
     tree[c].maxx=max(tree[c*2].maxx,tree[c*2+1].maxx);
     tree[c].minx=min(tree[c*2].minx,tree[c*2+1].minx);
}

int get_max(int c,int x,int y)
{
     if (tree[c].L==x && tree[c].R==y)
     return tree[c].maxx;
     int mid=tree[c].L+(tree[c].R-tree[c].L)/2;
     if (y<=mid) return get_max(c*2,x,y);
     else if (x>mid) return get_max(c*2+1,x,y);
     else return max(get_max(c*2,x,mid),get_max(c*2+1,mid+1,y));
}

int get_min(int c,int x,int y)
{
     if (tree[c].L==x && tree[c].R==y)
     return tree[c].minx;
     int mid=tree[c].L+(tree[c].R-tree[c].L)/2;
     if (y<=mid) return get_min(c*2,x,y);
     else if (x>mid) return get_min(c*2+1,x,y);
     else return min(get_min(c*2,x,mid),get_min(c*2+1,mid+1,y));
}

int get_diff(int x,int y)
{
     return get_max(1,x,y)-get_min(1,x,y);
}

int main()
{
     int n,m,x,y;
     while(scanf("%d%d",&n,&m)!=EOF)
     {
          for (int i=1;i<=n;i++) scanf("%d",&a[i]);
          build(1,1,n);
          while(m--)
          {
               scanf("%d%d",&x,&y);
               printf("%d\n",get_diff(x,y));
          }
     }
     return 0;
}

作者 chensunrise

poj 3264 Balanced Lineup,布布扣,bubuko.com

poj 3264 Balanced Lineup

标签:des   style   blog   color   get   os   

原文地址:http://www.cnblogs.com/chensunrise/p/3810998.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!