码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 1297 Children’s Queue

时间:2014-06-30 18:26:44      阅读:203      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   java   color   strong   


JAVA大数....

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10390    Accepted Submission(s): 3333


Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
 

Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 

Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 

Sample Input
1 2 3
 

Sample Output
1 2 4
 

Author
SmallBeer (CML)
 

Source
 


import java.util.*;
import java.math.*;

public class Main
{
	public static void main(String[] args)
	{
		Scanner cin=new Scanner(System.in);
		
		BigInteger[] a=new BigInteger[1100];
		a[1]=BigInteger.valueOf(1);
		a[2]=BigInteger.valueOf(2);
		a[3]=BigInteger.valueOf(4);
		a[4]=BigInteger.valueOf(7);
		for(int i=5;i<=1000;i++)
		{
			a[i]=a[i-4].add(a[i-2].add(a[i-1]));
		}
		
		while(cin.hasNextInt())
		{
			int n=cin.nextInt();
			System.out.println(a[n]);
		}
	}
}




HDOJ 1297 Children’s Queue,布布扣,bubuko.com

HDOJ 1297 Children’s Queue

标签:des   style   http   java   color   strong   

原文地址:http://blog.csdn.net/ck_boss/article/details/35860567

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!