码迷,mamicode.com
首页 > 其他好文 > 详细

HDU--2056

时间:2015-06-11 13:07:31      阅读:117      评论:0      收藏:0      [点我收藏+]

标签:hdu

Rectangles

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17131    Accepted Submission(s): 5522


Problem Description
Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .
 

Input
Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).
 

Output
Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.
 

Sample Input
1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00 5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50
 

Sample Output
1.00 56.25
 

Author
seeyou

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <cmath>
using namespace std;

int main()
{
	double x[4], y[4], x1, x2, y1, y2, s;
	while (cin >> x[0]>> y[0]>>x[1]>>y[1]>>x[2]>>y[2]>>x[3]>>y[3])
	{
		x1 = fabs(x[1] - x[0]);
		x2 = fabs(x[3] - x[2]);
		y1 = fabs(y[1] - y[0]);
		y2 = fabs(y[3] - y[2]);
		sort(x,x+4);
		sort(y,y+4);
		if ( (x[3]-x[0]) < x1+x2  &&  (y[3]-y[0]) < y1+y2)
		{
			s = ( x[2] -x[1]) * (y[2] - y[1]);
			printf("%.2lf\n",s);
		}
		else
			cout << "0.00"<< endl;
	}
	return 0;
}


HDU--2056

标签:hdu

原文地址:http://blog.csdn.net/xiaotan1314/article/details/46454571

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!