码迷,mamicode.com
首页 > 其他好文 > 详细

UVa 572 - Oil Deposits【图DFS】

时间:2015-06-16 23:06:33      阅读:311      评论:0      收藏:0      [点我收藏+]

标签:uva   572      acm   

Oil Deposits

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

input

The input file contains one or more grids. Each grid begins with a line containing mand n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 技术分享 and 技术分享. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*‘, representing the absence of oil, or `@‘, representing an oil pocket.

output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample output

0
1
2
2
输入一个m行n列的字符矩阵,统计字符“@”组成多少个八连块。如果两个字符“@”所在的格子相邻(横,竖,斜),就说它们属于同一个八连块。

#include<cstdio>
#include<cstring>
const int maxn=110;
char pic[maxn][maxn];
int id[maxn][maxn],m,n,cnt;
void DFS(int r,int c){
    if(r<0||r>=m||c<0||c>=n) return;//出界
    if(id[r][c]==1||pic[r][c]!='@') return;//不是"@"或者该格子访问过
    id[r][c]=1;//该格子做标记
    for(int dr=-1;dr<2;dr++)//用循环找相邻8个格子,也可用8条语句
        for(int dc=-1;dc<2;dc++)
            DFS(r+dr,c+dc);
}
int main()
{
    while(scanf("%d %d",&m,&n)==2&&m&&n){
        cnt=0;
        memset(id,0,sizeof(id));
        for(int i=0;i<m;i++)
            scanf("%s",pic[i]);
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
                if(id[i][j]==0&&pic[i][j]=='@')
                {
                    cnt++;
                    DFS(i,j);
                }
        printf("%d\n",cnt);
    }
    return 0;
}


UVa 572 - Oil Deposits【图DFS】

标签:uva   572      acm   

原文地址:http://blog.csdn.net/a995549572/article/details/46523037

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!