码迷,mamicode.com
首页 > 其他好文 > 详细

分子量(Molar Counting, ACM/ICPC Seoul 2007, UVa1586)

时间:2015-06-19 10:39:58      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:c   计算机专业   算法   考研   

An organic compound is any member of a large class of chemical compounds whose molecules contain carbon. The molar mass of an organic compound is the mass of one mole of the organic compound. The molar mass of an organic compound can be computed from the standard atomic weights of the elements.

When an organic compound is given as a molecular formula, Dr. CHON wants to find its molar mass. A molecular formula, such as C3 H4 O3 , identifies each constituent element by its chemical symbol and indicates the number of atoms of each element found in each discrete molecule of that compound. If a molecule contains more than one atom of a particular element, this quantity is indicated using a subscript after the chemical symbol.

In this problem, we assume that the molecular formula is represented by only four elements, C‘ (Carbon),H’ (Hydrogen), O‘ (Oxygen), andN’ (Nitrogen) without parentheses.

The following table shows that the standard atomic weights for C‘,H’, O‘, andN’.

Atomic Name Carbon Hydrogen Oxygen Nitrogen
Standard Atomic Weight 12.01 g/mol 1.008 g/mol 16.00 g/mol 14.01 g/mol

For example, the molar mass of a molecular formula C6 H5 OH is 94.108 g/mol which is computed by 6 × (12.01 g/mol) + 6 × (1.008 g/mol) + 1 × (16.00 g/mol).

Given a molecular formula, write a program to compute the molar mass of the formula.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case is given in a single line, which contains a molecular formula as a string. The chemical symbol is given by a capital letter and the length of the string is greater than 0 and less than 80. The quantity number n which is represented after the chemical symbol would be omitted when the number is 1 (2n99) .

Output

Your program is to write to standard output. Print exactly one line for each test case. The line should contain the molar mass of the given molecular formula.

Sample Input

4
C
C6H5OH
NH2CH2COOH
C12H22O11
Sample Output

12.010
94.108
75.070
342.296

#include <stdio.h>
#include <ctype.h>

int main() {
    int T;
    scanf("%d", &T);

    while (T--) {
        char s[100];
        scanf("%s", s);

        double sum = 0, num;
        for (int i = 0; s[i]; i++) {
            // 算出后两位所代表的数值
            if (isdigit(s[i+1])) {
                if (isdigit(s[i+2])) num = 10*(s[i+1]-‘0‘)+s[i+2]-‘0‘;
                else num = s[i+1] - ‘0‘;
            }
            else num = 1;

            // 判断第一位
            if (s[i] == ‘N‘) sum += 14.01*num;
            else if (s[i] == ‘C‘) sum += 12.01*num;
            else if (s[i] == ‘H‘) sum += 1.008*num;
            else if (s[i] == ‘O‘) sum += 16.00*num;
            else continue; 
        }
        printf("%.3lf\n", sum);
    }
    return 0;
}

分子量(Molar Counting, ACM/ICPC Seoul 2007, UVa1586)

标签:c   计算机专业   算法   考研   

原文地址:http://blog.csdn.net/zhou554291911/article/details/46554589

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!