码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4576 Robot(概率题)

时间:2014-07-03 13:49:37      阅读:251      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   

Robot


Problem Description
Michael has a telecontrol robot. One day he put the robot on a loop with n cells. The cells are numbered from 1 to n clockwise.

bubuko.com,布布扣


At first the robot is in cell 1. Then Michael uses a remote control to send m commands to the robot. A command will make the robot walk some distance. Unfortunately the direction part on the remote control is broken, so for every command the robot will chose a direction(clockwise or anticlockwise) randomly with equal possibility, and then walk w cells forward.
Michael wants to know the possibility of the robot stopping in the cell that cell number >= l and <= r after m commands.
 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains four integers: above mentioned n(1≤n≤200) ,m(0≤m≤1,000,000),l,r(1≤l≤r≤n).
Then m lines follow, each representing a command. A command is a integer w(1≤w≤100) representing the cell length the robot will walk for this command.  
The input end with n=0,m=0,l=0,r=0. You should not process this test case.
 

Output
For each test case in the input, you should output a line with the expected possibility. Output should be round to 4 digits after decimal points.
 

Sample Input
3 1 1 2 1 5 2 4 4 1 2 0 0 0 0
 

Sample Output
0.5000 0.2500
 

Source
 

题目大意:

第一行4个数字表示:一块圆盘上有n个格子,m个操作,l,r表示区间,接下来m行,每行1个数字w,机器人一开始在1号格子,对于每个操作会顺时针或者逆时针移动w格,问你最终停在区间[l,r]的概率。


解题思路:

去年去杭州比赛遇到了这题,当时因为这题超时打铁了,真心感觉自己当时弱爆了!!

现在回过头来看这题,好简单

第i号格子其实就是只能由 i-w号格子 与i+w号格子得来,而且概率各占1半,所以注意边界,用滚动的思想就行了。


解题代码:

#include <iostream>
#include <cstdio>
using namespace std;

const int maxn=210;
double p[maxn],q[maxn];
int n,m,l,r;

void solve(){
    double ans=0;
    for(int i=0;i<=n;i++) q[i]=p[i]=0;
    p[0]=1.0;
    for(int t=0;t<m;t++){
        int w;
        scanf("%d",&w);
        for(int i=0;i<n;i++){
            if(p[i]>0){
                q[(i+w)%n]+=p[i]*0.5;
                q[((i-w)%n+n)%n ]+=p[i]*0.5;
            }

        }
        for(int i=0;i<n;i++){
            p[i]=q[i];
            q[i]=0;
        }
    }
    for(int i=l-1;i<r;i++) ans+=p[i];
    printf("%.4lf\n",ans);
}

int main(){
    while(scanf("%d%d%d%d",&n,&m,&l,&r)!=EOF && (n||m||l||r) ){
        solve();
    }
    return 0;
}





HDU 4576 Robot(概率题),布布扣,bubuko.com

HDU 4576 Robot(概率题)

标签:des   style   blog   http   color   os   

原文地址:http://blog.csdn.net/a1061747415/article/details/36633147

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!