码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1952 BUY LOW, BUY LOWER (最长递减子序列+不同子序列计数)

时间:2014-07-03 15:58:07      阅读:225      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   strong   

BUY LOW, BUY LOWER
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 8327   Accepted: 2888

Description

The advice to "buy low" is half the formula to success in the bovine stock market.To be considered a great investor you must also follow this problems‘ advice: 
                    "Buy low; buy lower"

Each time you buy a stock, you must purchase it at a lower price than the previous time you bought it. The more times you buy at a lower price than before, the better! Your goal is to see how many times you can continue purchasing at ever lower prices. 

You will be given the daily selling prices of a stock (positive 16-bit integers) over a period of time. You can choose to buy stock on any of the days. Each time you choose to buy, the price must be strictly lower than the previous time you bought stock. Write a program which identifies which days you should buy stock in order to maximize the number of times you buy. 

Here is a list of stock prices: 
 Day   1  2  3  4  5  6  7  8  9 10 11 12

Price 68 69 54 64 68 64 70 67 78 62 98 87


The best investor (by this problem, anyway) can buy at most four times if each purchase is lower then the previous purchase. One four day sequence (there might be others) of acceptable buys is: 
Day    2  5  6 10

Price 69 68 64 62

Input

* Line 1: N (1 <= N <= 5000), the number of days for which stock prices are given 

* Lines 2..etc: A series of N space-separated integers, ten per line except the final line which might have fewer integers. 

Output

Two integers on a single line: 
* The length of the longest sequence of decreasing prices 
* The number of sequences that have this length (guaranteed to fit in 31 bits) 

In counting the number of solutions, two potential solutions are considered the same (and would only count as one solution) if they repeat the same string of decreasing prices, that is, if they "look the same" when the successive prices are compared. Thus, two different sequence of "buy" days could produce the same string of decreasing prices and be counted as only a single solution. 

Sample Input

12
68 69 54 64 68 64 70 67 78 62
98 87

Sample Output

4 2

Source


题意:

最长递减子序列+最长的不同子序列计数。


思路:(贴别人的)

注意:重复的只算一次
如何去掉一些重复的是本题的关键
去重思路:
7
5 3 7 6 3 2 1
6
5 3 7 3 1
5
5 3 2 1 3
第一组在推到 数字 2 的时候有 3会出现重复, 显然前面一个3是可有可无的。
第二组也一样,前面一个3是可有可无的。

1.如果最长下降序列中有后面一个3, 如第一二组数据,那么前面一个3是无用的,在推好后面一个3之后把之前的所用重复的计数数组清零

2.如果最长下降序列中只有前面一个3,如第三组数据, 做情况1的操作也是不会影响结果的,因为第三组的前面一个3的状态已经推到2后才被清零的。


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#define maxn 35
#define MAXN 100005
#define mod 100000000
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int n,m,ans,cnt,tot,k;
int dp[5005],num[5005],a[5005];

int main()
{
    int i,j,t;
    while(~scanf("%d",&n))
    {
        for(i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            a[i]=-a[i];
        }
        ans=0;
        for(i=1;i<=n;i++)
        {
            t=0;
            for(j=1;j<i;j++)
            {
                if(a[i]>a[j])
                {
                    if(t<dp[j])
                    {
                        t=dp[j];
                        num[i]=num[j];
                    }
                    else if(t==dp[j])
                    {
                        num[i]+=num[j];
                    }
                }
                else if(a[i]==a[j])
                {
                    num[j]=0;
                }
            }
            if(t==0) num[i]=1;
            dp[i]=t+1;
            if(ans<dp[i]) ans=dp[i];
        }
        int res=0;
        for(i=1;i<=n;i++)
        {
            if(dp[i]==ans) res+=num[i];
        }
        printf("%d %d\n",ans,res);
    }
    return 0;
}
/*
4
4 1 3 1
3
52 52 51
6
4 3 4 1 3 1
4
2 2 2 2
*/



poj 1952 BUY LOW, BUY LOWER (最长递减子序列+不同子序列计数),布布扣,bubuko.com

poj 1952 BUY LOW, BUY LOWER (最长递减子序列+不同子序列计数)

标签:des   style   blog   http   color   strong   

原文地址:http://blog.csdn.net/tobewhatyouwanttobe/article/details/36501321

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!