码迷,mamicode.com
首页 > 其他好文 > 详细

UVA10038 Jolly Jumpers

时间:2014-07-03 17:40:42      阅读:257      评论:0      收藏:0      [点我收藏+]

标签:uva10038

Problem E: Jolly Jumpers

A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n-1. For instance,

1 4 2 3
is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper.

Input

Each line of input contains an integer n <= 3000 followed by n integers representing the sequence.

Output

For each line of input, generate a line of output saying "Jolly" or "Not jolly".

Sample Input

4 1 4 2 3
5 1 4 2 -1 6

Sample Output

Jolly
Not jolly

题意是要相邻的两个数的绝对值在[1,n),而且这个范围内的每个数都要出现一次。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

int vis[3002];

int main()
{
	int n, a, b, ok, t, m;
	while(scanf("%d", &n) != EOF){
		scanf("%d", &a);
		m = n; ok = 1;
		memset(vis, 0, sizeof(vis));
		while(--n){
			scanf("%d", &b);
			
			if(ok == 0) continue;
			if((t = abs(a - b)) == 0 || t >= m || vis[t])
				ok = 0; 			
			
			a = b; vis[t] = 1;
		}
		printf(ok ? "Jolly\n" : "Not jolly\n");
	}
	return 0;
}


UVA10038 Jolly Jumpers,布布扣,bubuko.com

UVA10038 Jolly Jumpers

标签:uva10038

原文地址:http://blog.csdn.net/chang_mu/article/details/36429743

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!