码迷,mamicode.com
首页 > 其他好文 > 详细

uva 591 Box of Bricks

时间:2015-07-06 14:20:37      阅读:183      评论:0      收藏:0      [点我收藏+]

标签:uva591

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. Look, I‘ve built a wall!‘‘, he tells his older sister Alice.Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?
技术分享

Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1?n?50 and 1?hi?100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

Output
For each set, first print the number of the set, as shown in the sample output. Then print the line “ The minimum number of moves is k.”, where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height.

Output a blank line after each set.

Sample Input

6
5 2 4 1 7 5
0

Sample Output

Set #1
The minimum number of moves is 5.

Miguel A. Revilla
1998-03-10

#include<iostream>
#include<algorithm>
#include<map>
#include<cstdio>
#include<cstdlib>
#include<vector>
#include<cmath>
#include<cstring>
#include<string>
using namespace std;
const int maxn=55;
typedef long long LL;
int a[maxn];
int main(){
    #ifndef ONLINE_JUDGE
    freopen("Text//in.txt","r",stdin);
    #endif // ONLINE_JUDGE
    int n;
    int cas=1;
    while(~scanf("%d",&n)&&n){
        int sum=0,high=0;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        int avg=sum/n;
        int ans=0;
        for(int i=0;i<n;i++){
            if(a[i]<avg)ans+=avg-a[i];
        }
        printf("Set #%d\nThe minimum number of moves is %d.\n\n",cas++,ans);
    }
    return 0;
}

/*
Sample Input
2
12
-3646397
Sample Output
7
2701
*/

版权声明:本文为博主原创文章,未经博主允许不得转载。

uva 591 Box of Bricks

标签:uva591

原文地址:http://blog.csdn.net/u013167299/article/details/46772731

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!