码迷,mamicode.com
首页 > 其他好文 > 详细

钱币兑换问题

时间:2015-07-07 17:04:21      阅读:108      评论:0      收藏:0      [点我收藏+]

标签:

E - 钱币兑换问题
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

在一个国家仅有1分,2分,3分硬币,将钱N兑换成硬币有很多种兑法。请你编程序计算出共有多少种兑法。
 

Input

每行只有一个正整数N,N小于32768。
 

Output

对应每个输入,输出兑换方法数。
 

Sample Input

2934 12553
 

Sample Output

718831 13137761
 
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=32768+5;
int n;
int dp[maxn][5];
void init() {
    memset(dp,0,sizeof(dp));
    dp[1][1]=1;
    dp[1][2]=1;
    dp[1][3]=1;
    dp[2][1]=1;
    dp[2][2]=2;
    dp[2][3]=2;
    dp[3][1]=1;
    dp[3][2]=2;
    dp[3][3]=3;
    for(int i=4;i<maxn;i++)
    {
        for(int j=1;j<=3;j++)
        {
            if(j==1)dp[i][j]=1;
            else dp[i][j]=dp[i-j][j]+dp[i][j-1];
        }
    }
}
int main() {
    init();
    while(~scanf("%d",&n)) {
        printf("%d\n",dp[n][3]);
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

钱币兑换问题

标签:

原文地址:http://blog.csdn.net/qq_18661257/article/details/46789891

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!