码迷,mamicode.com
首页 > 其他好文 > 详细

HDU(1312)

时间:2015-07-11 09:16:35      阅读:160      评论:0      收藏:0      [点我收藏+]

标签:

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12211    Accepted Submission(s): 7601

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
here are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
 
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
 
Sample Output
45
59
6

13

//上下左右搜索查看与起点能连通的个数 

#include <stdio.h>
#include <iostream>
using namespace std;
char c[21][21];
int vis[21][21];
int n,m;
void dfs(int x,int y)
{
    if(x<0||y<0||x>=m||y>=n) return;  
    if(vis[x][y]==1) return;
    if(c[x][y]=='.'||c[x][y]=='@')  //起点也算一个
    {
        vis[x][y]=1;  //连通的标记为1
        dfs(x+1,y);
        dfs(x-1,y);
        dfs(x,y+1);
        dfs(x,y-1);
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m)&&(n+m))
    {
        for(int i=0;i<21;i++)
        {
            for(int k=0;k<21;k++)
            {
                c[i][k]=0;
                vis[i][k]=0;
            }
        }
        int x,y;
        for(int i=0;i<m;i++)
        {
            for(int k=0;k<n;k++)
            {
                cin>>c[i][k];  
                if(c[i][k]=='@')  //记录起点
                {
                    x=i;
                    y=k;
                }
            }
        }
        dfs(x,y);
        int cnt=0;
        for(int i=0;i<m;i++)  //遍历一遍看看有几个标记的
            for(int k=0;k<n;k++)
                if(vis[i][k]==1)
                    cnt++;
        printf("%d\n",cnt);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU(1312)

标签:

原文地址:http://blog.csdn.net/a73265/article/details/46835323

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!