码迷,mamicode.com
首页 > 其他好文 > 详细

[ACM] hdu 1260 Tickets (动态规划)

时间:2014-05-03 21:16:19      阅读:360      评论:0      收藏:0      [点我收藏+]

标签:acm   动态规划   

Tickets

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 2

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

 

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.

 

Input

 

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

 

Output

 

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

 

Sample Input

 

2
2
20 25
40
1
8

 

Sample Output

 

08:00:40 am
08:00:08 am

 

Source

 

浙江工业大学第四届大学生程序设计竞赛

 

解题思路:

一个人可以单独买票花费一定的时间,也可以两个人一起买票,也给定一个时间,给出K个人的单独买票时间和K-1个相邻的两个人一起买票的时间,问一共花费的最小时间。

用sin[i]为每个人单独买票的时间,dou[ i+1]为两个人一起买票的时间。

状态转移方程为: dp[i] = min(dp[i-1]+sin[i] , dp[i-2] + dou[i] )。当前第i个人分为两种情况,一是单独买,而是和前面的一块买。

代码:

#include <iostream>
#include <iomanip>
#include <algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn=2005;
int dp[maxn];
int sin[maxn];//每个人单独买票时间
int dou[maxn];//相邻两个人一块买票时间
int n,k;

int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&k);
        for(int i=1;i<=k;i++)
            scanf("%d",&sin[i]);
        for(int i=2;i<=k;i++)
            scanf("%d",&dou[i]);
        dp[0]=0;
        dp[1]=sin[1];
        for(int i=2;i<=k;i++)
            dp[i]=min(dp[i-1]+sin[i],dp[i-2]+dou[i]);
        int h=dp[k]/3600+8;
        int m=dp[k]/60%60;
        int s=dp[k]%60;
        if(h>12)
            cout<<setiosflags(ios::fixed)<<setw(2)<<setfill(‘0‘)<<h<<":"<<setw(2)<<m<<":"<<setw(2)<<s<<" pm"<<endl;
        else
            cout<<setiosflags(ios::fixed)<<setw(2)<<setfill(‘0‘)<<h<<":"<<setw(2)<<m<<":"<<setw(2)<<s<<" am"<<endl;
    }
    return 0;
}


 

[ACM] hdu 1260 Tickets (动态规划),布布扣,bubuko.com

[ACM] hdu 1260 Tickets (动态规划)

标签:acm   动态规划   

原文地址:http://blog.csdn.net/sr_19930829/article/details/24915887

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!