码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3069 Saruman's Army (简单贪心)

时间:2015-07-14 00:12:03      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:poj   贪心   


Saruman‘s Army
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5343   Accepted: 2733

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = ?1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source

Stanford Local 2006

题目链接:http://poj.org/problem?id=3069

题目大意:数轴上有些点,每个点可以放个什么鬼东西,可以覆盖R范围,问最少需要多少个这个东西

题目分析:好像是挑战那本书上的题,从左往右扫,找圆心位置即可



#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
int x[1005];

int main()
{
	int r,n;
	while(scanf("%d %d", &r, &n) != EOF && (r != -1 && n != -1))
	{
		for(int i = 0; i < n; i++)
			scanf("%d", &x[i]);
		sort(x, x + n);
		int ans = 0, i = 0;
		while(i < n)
		{
			int a1 = x[i++];
			while(i < n && x[i] <= a1 + r)
				i ++;
			int a2 = x[i - 1];
			while(i < n && x[i] <= a2 + r)
				i++;
			ans++;
		}
		printf("%d\n", ans);
	}
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

POJ 3069 Saruman's Army (简单贪心)

标签:poj   贪心   

原文地址:http://blog.csdn.net/tc_to_top/article/details/46868987

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!