码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1258 最小生成树

时间:2014-07-09 00:11:17      阅读:251      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   strong   width   os   

链接: http://poj.org/problem?id=1258
 
Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 38326   Accepted: 15424

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28


代码:
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>

#define minn 0x3f3f3f3f
#define maxx 105

int map[maxx][maxx],low[maxx],visit[maxx];
int n,m;

int prim()
{
    int i,j;
    int pos,result=0,min;
    memset(visit,0,sizeof(visit));
    visit[1]=1,pos=1;
    for(i=1;i<=n;i++)
    {
        if(i!=pos)
        {
            low[i]=map[pos][i];
        }
    }
    for(i=1;i<n;i++)
    {
        min=minn;
        for(j=1;j<=n;j++)
        {
            if(visit[j]==0 && min>low[j])
            {
                min=low[j];
                pos=j;
            }
        }
        result+=min;
        visit[pos]=1;

        for(j=1;j<=n;j++)
        {
            if(visit[j]==0 && low[j]>map[pos][j])
            {
                low[j]=map[pos][j];
            }
        }
    }
    return result;
}

int main()
{
    int i,j,k,t;

    while(scanf("%d",&n)!=EOF)
    {
        memset(map,minn,sizeof(map));
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%d",&map[i][j]);
            }
        }
        int result=prim();
        printf("%d\n",result);
    }
    return 0;
}

  

poj 1258 最小生成树,布布扣,bubuko.com

poj 1258 最小生成树

标签:des   blog   http   strong   width   os   

原文地址:http://www.cnblogs.com/ccccnzb/p/3830267.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!