码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2388 Who's in the Middle

时间:2014-07-08 13:30:10      阅读:144      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   strong   width   

Who‘s in the Middle
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 31149   Accepted: 18073

Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median‘ cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input

* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

Output

* Line 1: A single integer that is the median milk output.

Sample Input

5
2
4
1
3
5

Sample Output

3


#include<stdio.h>
#include<algorithm>
using namespace std;

int cmp(int x,int y)
{
	if(x<y)  return 1;
	else return 0;
}

int main ()
{
  int n,t,i,j;
  int a[1000005];
  while (~scanf("%d",&n))
  {
    for(i=0;i<n;i++)
	  scanf("%d",&a[i]);

	sort(a,a+n,cmp);
	if(n%2==0) t=(n/2)-1;
	else      t=n/2;
	printf("%d\n",a[t]);
  }
  return 0;
}



poj 2388 Who's in the Middle,布布扣,bubuko.com

poj 2388 Who's in the Middle

标签:des   style   blog   color   strong   width   

原文地址:http://blog.csdn.net/fyxz1314/article/details/37535393

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!