码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1001 Exponentiation

时间:2014-07-08 20:36:13      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:des   style   java   color   strong   width   

Exponentiation
Time Limit: 500MS   Memory Limit: 10000K
Total Submissions: 133146   Accepted: 32525

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don‘t print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201


import java.math.BigDecimal;
import java.util.Scanner;
public class Main{
	public static void main(String[] args) {
		Scanner cin=new Scanner(System.in);
		while(cin.hasNext())
		{
			BigDecimal a,c=BigDecimal.ONE;
			a=cin.nextBigDecimal();
			int n=cin.nextInt();
			for(int i=1;i<=n;i++)
			{
			  c=c.multiply(a);
			}
			String s=c.toPlainString().replace("0", " ").trim();
			if(s.charAt(s.length()-1)=='.')
				s=s.replace(".", "");
			System.out.println(s.replace(" ", "0"));
		}

	}

}



poj 1001 Exponentiation,布布扣,bubuko.com

poj 1001 Exponentiation

标签:des   style   java   color   strong   width   

原文地址:http://blog.csdn.net/fyxz1314/article/details/37519023

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!