码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1016 Prime Ring Problem

时间:2014-07-08 13:09:37      阅读:244      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   java   color   

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25144    Accepted Submission(s): 11229


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

bubuko.com,布布扣
 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
6 8
 

Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

<pre name="code" class="cpp">#include<stdio.h>
#include<algorithm>
#define max 100

int v[max];
int a[max];
int vis[max];
int i,n;

void dfs(int cur)
{
	if(cur==n && v[a[0]+a[n-1]])  //递归边界,测试第一个数和最后一个数。
	{
		for(i=0;i<n;i++)
		{
			if(i!=n-1) printf("%d ",a[i]);    //注意格式问题
			else printf("%d\n",a[i]);
		}
	}
	else
	{
		for(int i=2;i<=n;i++)                // 尝试放每一个数i
			if(!vis[i]&&v[i+a[cur-1]])       // 如果i没有用过,并且与前一个数之和为素数
			{
				a[cur]=i;    // i满足条件,则放入到数组a中
				vis[i]=1;    // 设置标记
				dfs(cur+1);
				vis[i]=0;    // 清除标记
			}
	}
}

int isprime(int n)   // 素数打表
{
	int k=1;
	for(int i=2;i<n/2;i++)
	{
		if(n%i==0)
			k=0;
	}
	return k;
}



int main()
{	
   int  p=1;
	while(~scanf("%d",&n))
	{
		for(i=1;i<=2*n;i++)
			v[i]=isprime(i);  //判断 1 到 2*n 中哪些是素数(若是素数则赋值为1)。v[2]=0,v[7]=1.....
		for(i=0;i<n;i++)
			a[i]=i+1;          //将数 1 到 n 存到数组a里面。 a[0]=1,a[1]=2,a[2]=3,a[3]=4......
		printf("Case %d:\n",p);
		dfs(1);
		p++;
		printf("\n");
	}
	return 0;
}






hdu 1016 Prime Ring Problem,布布扣,bubuko.com

hdu 1016 Prime Ring Problem

标签:des   style   blog   http   java   color   

原文地址:http://blog.csdn.net/fyxz1314/article/details/37344973

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!