码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2886 Who Gets the Most Candies? 【线段树】+【单点更新】+【模拟】+【反素数】

时间:2014-07-09 12:46:35      阅读:234      评论:0      收藏:0      [点我收藏+]

标签:poj2886

Who Gets the Most Candies?
Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 9416   Accepted: 2868
Case Time Limit: 2000MS

Description

N children are sitting in a circle to play a game.

The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (?A)-th child to the right.

The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 500,000) and K (1 ≤ K ≤ N) on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.

Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

Sample Input

4 2
Tom 2
Jack 4
Mary -1
Sam 1

Sample Output

Sam 3



泪奔T_T 这题做了一整个上午才过,主要卡在反素数的打表上,打得时候外层循环用的是maxn/2,导致有一半的因子表没有包含自身,因此错了N次,第二个卡点是一个点出圈后更新下个点的位置时总点数是改变的,第三个卡点就是线段树了,维护信息是区间未出圈的点数,在更新完即将出圈点的具体位置后即可直接插入。

//#define DEBUG
#include <stdio.h>
#include <string.h>
#define maxn 500002
#define lson l, mid, rt << 1
#define rson mid + 1, r, rt << 1 | 1

int tree[maxn << 2], div[maxn], temp;
struct Node{
	char name[12];
	int mov;
} stu[maxn], ans;

void countDiv()
{
	int i, j;
	for(i = 1; i <= maxn; ++i)
		for(j = i; j <= maxn; j += i)
			++div[j];
}

void build(int l, int r, int rt)
{
	tree[rt] = r - l + 1;
	if(l == r) return;
	
	int mid = (l + r) >> 1;
	build(lson);
	build(rson);
}

void update(int pos, int rank, int l, int r, int rt)
{
	--tree[rt];
	if(l == r){
		if(div[rank] > ans.mov){
			ans.mov = div[rank];
			strcpy(ans.name, stu[r].name);
		}
		temp = stu[r].mov;
		return;
	}
	
	int mid = (l + r) >> 1;
	if(tree[rt << 1] >= pos) update(pos, rank, lson);
	else update(pos - tree[rt << 1], rank, rson);
}

int getK(int k, int n)
{
	if(temp > 0) return (k + temp - 2) % n + 1;
	return ((k + temp - 1) % n + n) % n + 1;
}

int main()
{
	#ifdef DEBUG
	freopen("..\\stdin.txt", "r", stdin);
	freopen("..\\stdout.txt", "w", stdout);
	#endif
	
	countDiv();
	int n, k, i, rank;
	
	while(scanf("%d%d", &n, &k) == 2){
		build(1, n, 1);
		
		for(i = 1; i <= n; ++i)
			scanf("%s%d", stu[i].name, &stu[i].mov);
			
		rank = 1; ans.mov = 0;
		
		update(k, rank++, 1, n, 1);
		while(tree[1]){
			k = getK(k, tree[1]);
			update(k, rank++, 1, n, 1);			
		}
		
		printf("%s %d\n", ans.name, ans.mov);
	}
	return 0;
}


POJ2886 Who Gets the Most Candies? 【线段树】+【单点更新】+【模拟】+【反素数】,布布扣,bubuko.com

POJ2886 Who Gets the Most Candies? 【线段树】+【单点更新】+【模拟】+【反素数】

标签:poj2886

原文地址:http://blog.csdn.net/chang_mu/article/details/37562087

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!