码迷,mamicode.com
首页 > 其他好文 > 详细

STD第三场 HDU 5326

时间:2015-07-29 14:03:03      阅读:89      评论:0      收藏:0      [点我收藏+]

标签:2015多校联赛#3

Work

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 507    Accepted Submission(s): 355


Problem Description
技术分享


It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people. 
 

Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
 

Output
For each test case, output the answer as described above.
 

Sample Input
7 2 1 2 1 3 2 4 2 5 3 6 3 7
 

Sample Output

2

题意: 就是问你有 k条线的节点有多少个 可以并查集 也和暴力(比较喜欢:))

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
int n,k;
const int M = 105;
int a[M];

struct Edge
{;
    int x,y;
}p[M];

int fun(int m)
{
    if(a[m] == -1) a[m] = 1;
    for(int i = 0;i < n-1; i++)
            if(p[i].x == m) a[m] = a[m] + fun(p[i].y);
        return a[m];
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        for(int i = 0;i < n-1; i++)
        {
            scanf("%d%d",&p[i].x,&p[i].y);
        }

        memset(a,-1,sizeof(a));

        for(int i = 1 ;i <= n; i++)
            if(a[i] == -1) a[i] = fun(i);

        int cnt = 0;
        for(int i = 1 ;i <= n; i++)
        {
            if(a[i] == k+1)
                cnt++;
        }

        printf("%d\n",cnt);
    }
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

STD第三场 HDU 5326

标签:2015多校联赛#3

原文地址:http://blog.csdn.net/u012349696/article/details/47126575

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!