码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3371 最小生成树prim算法

时间:2014-07-12 12:53:40      阅读:226      评论:0      收藏:0      [点我收藏+]

标签:des   blog   java   strong   os   art   

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8992    Accepted Submission(s): 2519


Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

 

Sample Input
1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6
 

 

Sample Output
1
 

 

Author
dandelion
 
 
==================================================
也是经典的prim算法,就是处理有些麻烦,自己不是很细心
在定义了一个全局变量n后,又定义了一个局部变量n,导致出错很多次,总是调试不出来
并且,看别人的代码改了自己的代码,当n错误处理以后,又陷入输出-1的陷阱内,一波三折啊
 
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>

#define Maxint 0x7fffffff

int map[505][505],visit[505],low[505];
int n;

int prim()
{
    int i,j,pos=1,minn,sum=0;
    memset(visit,0,sizeof(visit));
    visit[pos]=1;

    for(i=1;i<=n;i++)
    {
        if(i!=pos)
        {
            low[i]=map[pos][i];
        }
    }

    for(i=1;i<n;i++)
    {
        minn=Maxint;pos=-1;//判断图的连通性
        for(j=1;j<=n;j++)
        {
            if(visit[j]==0 && minn>low[j])
            {
                minn=low[j];
                pos=j;
            }
        }

        if(pos == -1)return -1;
        visit[pos]=1;
        sum+=minn;

        for(j=1;j<=n;j++)
        {
            if(visit[j] == 0&&low[j]>map[pos][j])
            {
                low[j]=map[pos][j];
            }
        }
    }
    return sum;
}

int main()
{
    int m,k,t;
    int i,j;
    int p,q,c;
    int y,s;
    int str[505];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&k);
        for(i=1;i<=n;i++)
            for(j=1;j<=n;j++)
            {
                if(i==j)map[i][j]=0;
                else
                map[i][j]=Maxint;
                str[i]=Maxint;
            }

        for(i=1;i<=m;i++)
        {
            scanf("%d%d%d",&p,&q,&c);
            if(c<map[p][q])
            map[p][q]=map[q][p]=c;
        }
        for(i=1;i<=k;i++)
        {
            scanf("%d",&y);
            for(j=1;j<=y;j++)
            {
                scanf("%d",&str[j]);
            }
            for(j=1;j<=y;j++)
            {
                for(s=j+1;s<=y;s++)
                    map[str[j]][str[s]]=map[str[s]][str[j]]=0;
            }
        }
        bool flag=true;
        int result=prim();
        //for(i=1;i<=n;i++)
         //   if(visit == 0)
       // {
        //    flag=false;
        //}
        //if(flag)
        printf("%d\n",result);
       // else
           // printf("-1\n");
    }
    return 0;
}

/*

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define MAXN 510

int map[MAXN][MAXN], lowcost[MAXN];
bool visit[MAXN];
int alr[MAXN];
int num, sum;

void prim()
{
    int temp, k;
    memset(visit, false, sizeof(visit));
    for(int i = 1; i <= num; ++i)
        lowcost[i] = map[1][i];
    sum = 0;
    visit[1] = true;
    for(int i = 1; i <= num; ++i)
    {
        temp = INF;
        for(int j = 1; j <= num; ++j)
            if(!visit[j] && temp > lowcost[j])
                temp = lowcost[k = j];
        if(temp == INF)
            break;
        visit[k] = 1;
        sum += temp;
        for(int j = 1; j <= num; ++j)
            if(!visit[j] && lowcost[j] > map[k][j])
                lowcost[j] = map[k][j];
    }
}

int main()
{
    int ncase;
    int road, already;
    int a, b, cost;
    int nodenum, node;
    bool flag;
    scanf("%d", &ncase);
    while(ncase--)
    {
        flag = true;
        memset(alr, INF, sizeof(alr));
        memset(map, INF, sizeof(map));
        scanf("%d%d%d", &num, &road, &already);
        for(int i = 1; i <= road; ++i)
        {
            scanf("%d%d%d", &a, &b, &cost);
            if(cost < map[a][b])
                map[a][b] = map[b][a] = cost;
        }
        for(int i = 1; i <= already; ++i) //处理这些权值为0的边
        {
            scanf("%d", &nodenum);
            for(int j = 1; j <= nodenum; ++j)
                scanf("%d", &alr[j]);
            int k;
            for(int j = 1; j < nodenum; ++j)
            {
                k = j + 1;
                map[alr[j]][alr[k]] = map[alr[k]][alr[j]] = 0;
            }
        }
        prim();
        for(int i = 1; i <= num; ++i) //判断图的连通性
            if(visit[i] == false)
                flag = false;
        if(flag)
            printf("%d\n", sum);
        else
            printf("-1\n");
    }
    return 0;
}

*/

  给出了两种判断图连通的方法

 

hdu 3371 最小生成树prim算法,布布扣,bubuko.com

hdu 3371 最小生成树prim算法

标签:des   blog   java   strong   os   art   

原文地址:http://www.cnblogs.com/ccccnzb/p/3832703.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!